Anatolevich_Kulikov1229
?>

Написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет" const n=20; var a: array [1..n] of integer; i, j, max: integer; begin for i: = 1 to n do readln(a[i]); max: =99; j: =a[i]; for i: = 1 to n do if (j> 99) and (j< 999) and (j mod 9 < > 0) and (j> max) then max: =j; if max> 99 then writeln (max) else writeln ('no'); readln; end. программа проверяет только последнее число, а не все 20. где ошибка?

Информатика

Ответы

testovvanya
  const n=20;     var a: array [1..n] of integer; i,j,max,k: integer; begin max: =99;   for i: = 1 to n do   begin   readln(a[i]);   j: =a[i];   for k: = 1 to n do   begin     if (j> 99) and (j< 999) and (j mod 9 < > 0) and (j> max) then max: =j;   end;   end;   if max> 99 then writeln (max) else writeln ('no'); end.
ariyskayaa5
Ябы написал легче, но тут ошибка в цикле, после объявление цикла начни begin, а после if max> 99 end; именно "; "
TatianaSeliverstova64

ответ:

5 run length limited — rll.

на сегодняшний день одни из самых популярных методов является кодирование информации с ограничением длины поля записи. этому способу на диске можно разместить в полтора раза больше данных, нежели в процессе записи по методу mfm. используя этот метод происходит кодирование не отдельного бита, а целой группы.

6 синхронизация -в процессе работы с цифровой информацией особенное значение получает синхронизация. в момент считывания либо записи информации немаловажным остается точное определение времени каждой смены знака. если синхронизации нет, то период смены знака может определяться неправильно. в итоге этого неизбежной будет потеря или искажение данных.

kononenko-elena4
Если программа нужна на паскале, то вот держите program arrayz; uses crt; // подключение модуля crt var  z: array[1..4, 1..3] of integer; // массив  i, j, n, o: integer; // переменные для циклов и счета отрицательных и нечетных элементов begin  randomize; // нужно для turbopascal  // заполнение массива  for i : = 1 to 4 do  begin    writeln; // переход на другую строку    for j : = 1 to 3 do    begin      z[i, j] : = random(60) - 30; // рандомное заполнение массива      write(z[i, j]: 8); // вывод в консоль массива    end;   end;   // нахождение отрицательных и нечетных элементов  for i : = 1 to 4 do    for j : = 1 to 3 do    begin      if z[i, j] mod 2 < > 0 then // нахождение нечетных элементов        n : = n + 1;       if z[i, j] < 0 then // нахождение отрицательных элементов        o : = o + 1;     end;     writeln; // переход строки чтобы не было конфликтов  writeln('нечетных элементов: ', n, ' | отрицательных элементов: ', o); // вывод результатаend.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет" const n=20; var a: array [1..n] of integer; i, j, max: integer; begin for i: = 1 to n do readln(a[i]); max: =99; j: =a[i]; for i: = 1 to n do if (j> 99) and (j< 999) and (j mod 9 < > 0) and (j> max) then max: =j; if max> 99 then writeln (max) else writeln ('no'); readln; end. программа проверяет только последнее число, а не все 20. где ошибка?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

jim2k
Ильдар-Кугай
Strelkov-Roman1263
innaterenina
des-32463
Galkin Vladimirovich729
deputy810
Екатерина655
vik-2202
ele922009226536
TrubnikovKlimenok926
elenarumack
Александра_Наталья1417
cheshirsky-kot
pravovoimeridian
▲