#include <stdio.h>
#include <conio.h>
#include <locale.h>
main()
{
setlocale(0, "");
int n;
printf("Введите размер массива: ");
scanf("%d", &n);
int A[n];
printf("Введите элементы массива: ");
for (int i = 0; i < n; i++)
{
scanf("%d", &A[i]);
}
int check = 0;
for (int i = 0; i < n - 1; i++)
{
if (A[i] == A[i + 1])
{
check++;
break;
}
}
if (check != 0)
{
printf("YES");
}
else
{
printf("NO");
}
getch();
}
Объяснение:
#include <stdio.h> // Библиотека ввода-вывода
#include <conio.h> // Библиотека, содержащая функцию getch() - пауза
#include <locale.h> // Библиотека локализации
main()
{
setlocale(0, ""); // Локализация
int n; // Создание целочисленной переменной, являющейся размером массива
printf("Введите размер массива: "); // Вывод сообщения в консоль
scanf("%d", &n); // Ввод размера массива с клавиатуры
int A[n]; // Создание целочисленного массива A размера n
printf("Введите элементы массива: "); // Вывод сообщения в консоль
for (int i = 0; i < n; i++) // Заполнение массива с клавиатуры
{
scanf("%d", &A[i]); // Заполнение массива с клавиатуры
}
int check = 0; // Переменная, для проверки на пары одинаковых элементов
for (int i = 0; i < n - 1; i++) // Идем по всему массиву
{
if (A[i] == A[i + 1]) // Если элемент i = следующему после себя элементу
{
check++; // К переменной check прибавляем единицу
break; // Выходим из цикла for
}
}
if (check != 0) // Если значение переменной check ≠ 0
{
printf("YES"); // Выводим "YES"
}
else // Иначе
{
printf("NO"); // Выводим "NO"
}
getch(); // Для завершения программы необходимо нажать любую клавишу
}
Поделитесь своими знаниями, ответьте на вопрос:
составьте алгоритм для решения с алгоретмических структур: 1. цикл с предусловием 2. цикл с постусловием запишите эти алгоритмы на языке блок схем. напишите программу на языке программирования паскаль. : введите с клавиатуры последовательность чисел (конец ввода 0 найдите минимальное чётное число.
Последняя цифра числа - остаток деления на N, где N - основание системы счисления. Соответственно, последние две цифры - остаток от деления на N^2.
12₄ = 1*4 + 2 = 6₁₀
Выходит, что нам нужно найти все десятичные числа, которые не превосходят 40 и при делении на 16 дают остаток 12.
Общий вид таких чисел: k*16 + 6. K - любое целое неотрицательное число. Теперь просто подставляем.
если k = 0, то получается число 5.
если k = 1, то получается число 22.
если k = 2, то получается число 38.
Очевидно, что дальше мы выйдем за границы нужного нам диапазона.
ответ: 5, 22, 38