braigon974
?>

Прошу 1.напишите программу для нахождения объема шара, имеющего радиус r по формуле v=4/3r^3 2.напишите программу вычисления стоимости покупки дано: цена сахара - х руб кол-во сахара - 3 кг цена муки - y руб кол-во муки - 5 кг цена риса - z руб кол-во риса - 1 кг найти стоимость покупки

Информатика

Ответы

prostopo4ta29
Program s; uses crt; var v,r: real; begin writeln('введите радиус: '); read(r); v: =(4/3)*pi*(sqr(r)*r); writeln('объем равен: ',v: 2: 2); end. program s; uses crt; var x,y,z,x1,y1,z1,r: real; begin writeln('введите цену сахара: '); read(x); writeln('количество купленного сахара (кг): '); read(x1); writeln('введите цену муки: '); read(y); writeln('количество купленной муки: '); read(y1); writeln('введиет цену риса: '); read(z); writeln('количество купленного риса: '); read(z1); r: =(x*x1)+(y*y1)+(z*z1); writeln('стоимость покупки ',r); end.
ЕВ1873

//попробуйте мой вариант:

program chislo;

var n, k, i, raz: integer;

begin

    write('сколько чисел нужно сгенерировать: ');

    readln(n);

    write('число которое нужно посчитать (k): ');

    readln(k);

    for i: =1 to n do

        if random(0,100) = k then

            raz: =raz+1;

    writeln( 'из ', n, ' cгенирировандных чисел число ', k, ' встретилось ', raz, ' раз(а)');

end.

muzaffarovich-Sergei1777
Program n1; var i, n: integer; x,y : array[1..100] of integer; per: real; function dlina(x1,x2,y1,y2 : integer) : real; begin dlina : = sqrt(sqr(x2-x1) + sqr(y2-y1)); end; begin write('введите кол-во сторон: '); readln(n); per : = 0; write('введите x1 координату: '); readln(x[1]); write('введите y1 координату: '); readln(y[1]); for i: =2 to n do begin write('введите х',i,' координату: '); readln(x[i]); write('введите y',i,' координату: '); readln(y[i]); per : = per + dlina(x[i-1],y[i-1],x[i],y[i]); end; per : = per + dlina(x[i],y[i],x[1],y[1]); writeln('периметр искомого ',n,' угольника',per); readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Прошу 1.напишите программу для нахождения объема шара, имеющего радиус r по формуле v=4/3r^3 2.напишите программу вычисления стоимости покупки дано: цена сахара - х руб кол-во сахара - 3 кг цена муки - y руб кол-во муки - 5 кг цена риса - z руб кол-во риса - 1 кг найти стоимость покупки
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yugraspets
vadimkayunusov
Bogdanov
Litvin_Ivanov
ayanrsadykov
anechcak
Александровна
sergeykirushev
petrosyan35
mihalevskayat
pravovoimeridian
rsksnb
AverinAA6077
dimiff5
mamanger