Var s: string; i: integer; begin write ('введите строку: '); read(s); for i: =1 to length(s) do if s[i]='о' then s[i]: ='*'; write ('полученная строка: ',s); end.
Oksana-Kirakosyan1301
18.10.2021
Const n = 20; var a, b: array[1..n] of integer; i, j: integer; begin writeln('массив a: '); for i : = 1 to n do begin a[i] : = random(199) - 99; write(a[i] : 4); if (a[i] > 0) and (a[i] mod 3 = 0) then begin j : = j + 1; b[j] : = a[i]; end; end; writeln; writeln('массив b: '); for i : = 1 to j do write(b[i] : 4); end. пример работы программы: массив a: 3 73 -1 -35 97 -14 25 34 -79 5 -39 39 45 96 -85 -59 -14 76 -53 -12 массив b: 3 39 45 96
toxicfish
18.10.2021
Procedure prime(n: integer); var i: integer; begin for i : = 2 to round(sqrt(n)) do if n mod i = 0 then begin writeln('число ', n, ' составное'); exit end; writeln('число ', n, ' простое') end; begin prime(3); prime(8); prime(23); prime(35); end. вывод: число 3 простое число 8 составное число 23 простое число 35 составное
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу, которая заменяет все буквы "о" на символ "*" в строке s. использовать можно функции pos, length, copy, delete, insert.