Nikolaevna382
?>

Найти максимальный диагональный элемент и указать его координаты в главной диагонали матрицы, написать программу

Информатика

Ответы

Posadskii-Sergeevna
Uses crt; const  h=100; var  a: array [1..h,1..h] of integer;   n,x,y,max: integer; begin  write('длина матрицы= '); readln(n);   // enter  for x: =1 to n do    for y: =1 to n do    begin      write('a[',x,',',y,']= ');         readln(a[x,y]);     end;   //  max: =a[1,1];   while x< > n do  begin    if a[x,x] > max then      begin      max: =a[x,x];       y: =x;     end;     inc(x);   end;   writeln('максимальный элемент равен ',max,'.его координаты (',y,'; ',y,').');   end.
tarrin-ka

1. процессор – это блок эвм, предназначенный для автоматического считывания команд программы, их расшифровки и выполнения.

2. этот блок отвечает за выработку последовательности функциональных сигналов, нужной для корректного выполнения заданной команды. как правило, такие преобразования реализуются за несколько тактов. устройство обеспечивает автоматическое выполнение программы. при этом задействуются необходимые координированные ответвления работы прочих составляющих компонентов машины. за действие устройства отвечает базовый принцип микропрограммирования, имеющий четкое число характеристик.

3. программи́рование ( наверное).

4. алгоритм.

5. разрядность.

6. тактовая частота.

7. в 3 раза быстрее

vlsvergun59

program graduate;

var age: integer;

    institute: string;

    school: string;

begin

  writeln('введите возраст: ');

  readln(age);

  if age > 17 then

    begin

    writeln('введите ваш университет: ');

    readln(institute);

    writeln('хороший институт');

    end

  else

    begin

    writeln('введите вашу школу: ');

    readln(school);

    writeln('хорошая школа');

    end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Найти максимальный диагональный элемент и указать его координаты в главной диагонали матрицы, написать программу
Ваше имя (никнейм)*
Email*
Комментарий*