saniopt
?>

Изначально, была такая: на вход программы подается натуральное число. требуется написать программу, которая определяет составное или простое число на входе и выводит сумму его цифр. я написал первую часть программы (без вывода суммы цифр) : program sg3; uses crt; var i, a, k: integer; begin clrscr; write('введите число: '); readln(a); k: =0; for i: =2 to a div 2 do if a mod i =0 then k: =k+1; if k=0 then write('простое') else writeln('составное'); readln; end. допишите код, который бы выводил сумму цифр, паскаль

Информатика

Ответы

Исмагилова_Саният
Program sg3; uses crt; var i,a,k, sum: integer; begin clrscr; write('введите число: '); readln(a); k: =0; for i: =2 to a div 2 do if a mod i =0 then k: =k+1; if k=0 then write('простое') else writeln('составное'); while (a< > 0) do begin sum: =sum+(a mod 10); a: =a div 10; end; write('сумма цифр= ',sum); end.
Grishanin
Источники аналоговой информации(непрерывной): 1.        скрипка. может создавать звук любой высоты. переход от тона к тону происходит плавно и непрерывно. 2.        телевизор. луч кинескопа плавно и непрерывно перемещается по экрану, и яркость отдельных участков меняется плавно. 3.        телефон, громкость звука меняется плавно и непрерывно. 4.        картина, нарисованная художником с использованием большого количества оттенков красок. 5.        графики функций.   источники цифровой (дискретной)  информации. 1.        фортепьяно . нельзя исполнить звуки между нотами «ми» и «фа». переход от ноты к ноте осуществляется скачком. 2.        монитор. яркость луча изменяется скачком – есть луч )яркая белая или цветная точка), нет луча (черная точка). 3.        музыкальный проигрыватель компакт дисков. 4.        компьютер 5.        мобильные телефоны. аналоговую информацию можно превратить в цифровую (для этого достаточно, например, разным цветам присвоить номер или музыку записать нотами) и наоборот.
yakushkinayuliya
Источники аналоговой(непрерывной) информации: 1.        скрипка. может создавать звук любой высоты. переход от тона к тону происходит плавно и непрерывно. 2.        телевизор. луч кинескопа плавно и непрерывно перемещается по экрану, и яркость отдельных участков меняется плавно. 3.        телефон, громкость звука меняется плавно и непрерывно. 4.        картина, нарисованная художником с использованием большого количества оттенков красок. 5.        графики функций.   источники цифровой (дискретной)информации. 1.        фортепьяно . нельзя исполнить звуки между нотами «ми» и «фа». переход от ноты к ноте осуществляется скачком. 2.        монитор. яркость луча изменяется скачком – есть луч )яркая белая или цветная точка), нет луча (черная точка). 3.        музыкальный проигрыватель компакт дисков. 4.        компьютер 5.        мобильные телефоны. аналоговую информацию можно превратить в цифровую (для этого достаточно, например, разным цветам присвоить номер или музыку записать нотами) и наоборот.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Изначально, была такая: на вход программы подается натуральное число. требуется написать программу, которая определяет составное или простое число на входе и выводит сумму его цифр. я написал первую часть программы (без вывода суммы цифр) : program sg3; uses crt; var i, a, k: integer; begin clrscr; write('введите число: '); readln(a); k: =0; for i: =2 to a div 2 do if a mod i =0 then k: =k+1; if k=0 then write('простое') else writeln('составное'); readln; end. допишите код, который бы выводил сумму цифр, паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lenalevmax7937
Белов_Лукина1339
Андреевич
diana-020
kep92
Кристина Валентиновна
Кожуховский398
delfa-r6289
kmb1960679
Yurevna
Рафаэль633
Некрасова-И
sport2293032
jnrhjq3597
Alekseevich_Elena
▲