gri-7410
?>

Напишите программу для вычисления коэффицента естественного прироста населения по формуле : к=((а-в)/с)*1000; где к-коэффицент естественного прироста населения (в процентах), а- количество новорожденных ; в-количество умерших; с-среднегодовое количество населения

Информатика

Ответы

dkvsadovoe
На с++: #include < iostream> using namespace std; int main() { setlocale (lc_all, "russian"); double a, b, c; cout < < "введите кол-во новорождённых: "; cin > > a; cout < < "введите кол-во умерших: "; cin > > b; cout < < "введите среднегодовое кол-во населения: "; cin > > c; cout < < "коэффициент естественного прироста: " < < ((a-b)/c)*1000 < < endl; system ("pause"); }
Валерьевна1601
Помимо оперативной памяти, компьютеру необходима дополнительная память для долговременного размещения данных. такие устройства называются взу (внешние запоминающие устройства). различные способы хранения и записи информации служат для разных целей,  на сегодняшний день не существует универсального взу, которое может быть использовано как постоянное и переносное одновременно, и при этом быть доступным рядовым пользователям. информацию необходимо сохранять на носителях, не зависящих от наличия напряжения, и таких размеров, которые превышают возможности всех современных видов первичной памяти. сравнительно долговременное хранилище данных, расположенное вне системной платы компьютера, называется вторичным хранилищем данных (secondary storage). внешняя (долговременная) память — это место длительного хранения данных (программ, результатов расчётов, текстов и т. не используемых в данный момент в оперативной памяти компьютера. внешняя память, в отличие от оперативной, является энергонезависимой. носители внешней памяти, кроме того, обеспечивают транспортировку данных в тех случаях, когда компьютеры не объединены в сети (локальные или ). для работы с внешней памятью необходимо наличие накопителя (устройства, обеспечивающего запись и (или) считывание информации) и устройства хранения — носителя.  в своей работе я рассмотрю следующие запоминающие устройства: винчестеры, дискеты, стримеры, mo-накопители, оптические: cd-r, cd-rw, dvd-r, dvd-rw, и новейшие запоминающие устройства. 
bg1967bg
Program gt; var a: array[1..100000]of integer; i,h,j,k,p: integer; begin randomize; readln(h); for i: =1 to h do begin a[i]: =random(101)-50; write(a[i],' '); end; writeln; for i: =1 to h-1 do for j: =1 to h-1 do begin k: =a[j+1]; if(a[j]> a[j+1])then begin a[j+1]: =a[j]; a[j]: =k; end; end; p: =0; k: =1; for i: =2 to h do begin if(a[i]=a[i-1])then k: =k+1; if(a[i]< > a[i-1])or(i=h)then   begin if(k> =2)then begin p: =p+1; writeln(a[i-1],' ',a[i-1]); end; k: =1; end; end; writeln(p,' кол-во парных чисел без повторений'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для вычисления коэффицента естественного прироста населения по формуле : к=((а-в)/с)*1000; где к-коэффицент естественного прироста населения (в процентах), а- количество новорожденных ; в-количество умерших; с-среднегодовое количество населения
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Zhilinoe134
shuramuji
annakorolkova79
ilonchick679
Романенко
cleopatra1959
d5806252
Strelkov567
gk230650
Михеев557
Сергей
Ivanovich-A.V
Хохлов
Константиновна
▲