Евгеньевич Балиловна1398
?>

Добрые люди, ; ) заменить цифры от 1 до 10 словами. например: 1 - "один" и т.д. составить программу и блок-схему.

Информатика

Ответы

samiramoskva
Заменяет в строке var   s : string;   i, lim : integer; begin   readln (s);   i : = 1;   lim : = length (s);   while (i < = lim) do   begin     if s[i] in ['1'..'9'] then     begin       if (s[i] = '1') and (i < > length (s)) and (s[i+1] ='0') then       begin         write ('ten');         inc (i);       end       else       case s[i] of         '1' : write ('one');         '2' : write ('two');         '3' : write ('three');         '4' : write ('four');         '5' : write ('five');         '6' : write ('six');         '7' : write ('seven');         '8' : write ('eight');         '9' : write ('nine');       end;     end     else write (s[i]);     inc (i);   end; end.
myxa120283
Var  k: integer;   begin read(k);     if k=1 then write('один');     if k=2 then write('два');     if k=3 then write('три');     if k=4 then write('четыре');     if k=5 then write('пять');         if k=6 then write('шесть');         if k=7 then write('семь');         if k=8 then write('восемь');     if k=9 then write('девять');       if k=10 then write('десять');   end. 
Yurevich1291
      int sum = 0,pro = 1;       int a[15];       for (int i=0; i< 15; i++)       {               cin> > a[i];       }       for (int i=0; i< 15; i++)       {               if (a[i]> 0) sum = sum+a[i];                 else if (a[i]< 0) pro = pro * a[i];       }       cout< < "cумма положительных: "< < sum;       cout< < "произведение отрицательных: "< < pro;       if (sum> pro) cout< < "cумма больше";         else if (sum< pro) cout< < "произведение больше";           else cout< < "числа равны";       return 0;
Varagyant
Program programma; uses crt; var a,b,s: real; begin clrscr;           write('катет a = ');           readln(a);                     write('катет b = ');           readln(b);           writeln;                     if (a< =0) or(b< =0) then           write('катет не может быть отрицательным или равняться 0')           else           begin           s: =0.5*a*b;           write('площадь прямоугольного треугольника s = ', s: 0: 3);           end; end.          

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Добрые люди, ; ) заменить цифры от 1 до 10 словами. например: 1 - "один" и т.д. составить программу и блок-схему.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

apro3444595
info6
mishapavlov9
Алиференко_Елена342
Chistova-Dmitrii1162
Nadezhda
Смирнов_Андрей691
vasilevam
Борисов
marusyamr
MislitskiiSergei1403
alyans29
vikanikita
dksvetlydir
Sergei