olma-nn477
?>

, с информатикой, вот такое вот задание: Из натурального трехзначного числа удалить заданную цифру. Число и цифру вводить с клавиатуры. Пытаюсь написать программу, но что-то в ней не так - кто знает, подскажите, что именно, вот мой код для решения: program chislo; var ch, xy, z: integer; writeln('введите трёхзначное число:'); readln(ch); writeln('введите цифру, которую нужно удалить из числа:'); readln(x); if z=ch mod 10 then begin xy:=ch div 10; writeln('полученное двухзначное число равно ', xy); end; else if z=(ch div 10) mod 10 then begin xy:=(ch div 100)*10+ch mod 10; writeln('полученное двухзначное число равно ', xy); else if z=ch div 100 then begin xy:=ch mod 100; writeln('полученное двухзначное число равно ', xy); end; else writeln('такой цифры в числе нет'); end.

Информатика

Ответы

vladexi
Невнятно как-то сформулировано - то индексы найти, то массива нету... Пишу, как понял.

ОТДЕЛ Задание+;
ИСПОЛЬЗУЕТ Вывод ИЗ "...\Отделы\Обмен\";

ПЕР
  массив: РЯД 15 ИЗ ВЕЩ;
  сч, найдено: ЦЕЛ;
  найденное, индексы: ДОСТУП К РЯД ИЗ ВЕЩ;

УКАЗ
  найдено := 0;
  СОЗДАТЬ(индексы, РАЗМЕР(массив) - 1);
  ОТ сч := 1 ДО РАЗМЕР(массив) - 1 ВЫП
    ЕСЛИ массив[сч] = массив[0] ТО
      найденное[найдено] := сч;
      УВЕЛИЧИТЬ(найдено)
    КОН
  КОН;
  ЕСЛИ найдено = 0 ТО Вывод.Цепь("Не найдено.")
  ИНАЧЕ
    СОЗДАТЬ(индексы, найдено);
    ОТ сч := 0 ДО найдено - 1 ВЫП
      индексы[сч] := найденное[сч]
    КОН;
    найденное := ПУСТО
  КОН

КОН Задание.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

, с информатикой, вот такое вот задание: Из натурального трехзначного числа удалить заданную цифру. Число и цифру вводить с клавиатуры. Пытаюсь написать программу, но что-то в ней не так - кто знает, подскажите, что именно, вот мой код для решения: program chislo; var ch, xy, z: integer; writeln('введите трёхзначное число:'); readln(ch); writeln('введите цифру, которую нужно удалить из числа:'); readln(x); if z=ch mod 10 then begin xy:=ch div 10; writeln('полученное двухзначное число равно ', xy); end; else if z=(ch div 10) mod 10 then begin xy:=(ch div 100)*10+ch mod 10; writeln('полученное двухзначное число равно ', xy); else if z=ch div 100 then begin xy:=ch mod 100; writeln('полученное двухзначное число равно ', xy); end; else writeln('такой цифры в числе нет'); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

banketvoshod
Yumashev
myxa120283
ksoboleva
mitin228133770
yorestov
lirene
shhelina
baeva-larisa8165
mototeh69
Матвеев
Zelinskaya-Andrei
arbekova
Kondratev Ruzavina22
info2471
▲