kononenko-elena4
?>

Напишите программу в паскале! дано предложение.вывести на экран слова, начинающиеся и оканчивающиеся на одну и ту же букву.

Информатика

Ответы

Kuzminastia20038
Var a,t: string; b: array[1..100]of string; j,i,k,n: integer; begin writeln('vvedite predlojenie'); readln(a); a: =' '+a; for i: =1 to length(a) do if a[i]=' 'then inc(k) else b[k]: =b[k]+a[i]; writeln('slova s odinakovymi 1 i posledney bukvoy'); for i: =1 to k do begin t: =b[i]; if t[1]=t[length(t)] then write(t,' '); end; writeln; writeln ('slova s 3 e'); for i: =1 to k do begin n: =0; t: =b[i]; for j: =1 to length(t) do if t[j]='e' then inc(n); if n=3 then write (t,' '); end; writeln; writeln('slova s bukvoy o'); for i: =1 to k do begin n: =0; t: =b[i]; for j: =1 to length(t) do if t[j]='o' then n: =1; if n=1 then write (t,' '); end; end.
Мирзоев Денис
Var   a: array[1..4,1..4]of integer;   i,j,max: integer; begin     max: =-maxint;       for i : = 1 to 4 do        for j: =1 to 4 do         begin                read(a[i,j]);                   if (i=j) and (a[i,j]> max) then max: =a[i,j];             end;           writeln('max = ',max);     end.abs pascal
mkrtchyananaida6995
Uses crt; var a: array [1..5] of   integer;   i,m,n: integer;     f,g: text; begin clrscr;     write('m,n = '); read (m,n); randomize;     assign(f,'f.txt'); rewrite(f); //в фаил   for i: =1 to 5 do begin a[i]: =random(10);           write(f,a[i]: 2); end; close(f); assign(g,'g.txt'); rewrite(g); //в фаил for i: =1 to 5 do                     if ((a[i] mod m) = 0) and ((a[i] mod n) < > 0) then write(g,a[i]: 2);           close(g);   end.abc pascal

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в паскале! дано предложение.вывести на экран слова, начинающиеся и оканчивающиеся на одну и ту же букву.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ANDREY261965
Daletskaya Sergei1121
Александрович Алексеевна
pryvalovo48
Rjkjneirbyf555
tvtanya80
tsigankova2018
shakmeev
Peshkov
waspmoto6188
miha23727
boldireve617
prostopo4ta29
Ulianev77
kruttorg