panstel
?>

Написать программу вычисления стоимости покупки, состоящей из нескольких тетрадей и такого же количества обложек к ним. программа должна запросить цену тетрадей, цену обложек, и их количество вывести стоимость покупки.

Информатика

Ответы

GridnevaVNIGNI"
Program lol; uses crt; var ct,co,sum: real; ko,ky: integer; begin writeln('введите кол-во терадей: '); read(ky); writeln('введите цену за 1 тетрадь: '); read(ct); writeln('введите кол-во обложек: '); read(ko); writeln('введите цену за 1 обложку: '); read(co); sum: =(ky*ct)+(ko*co); writeln('стоимость покупки = ', sum); end.
Irina_Nikolai
Var     i,su1,su2: integer; a: array[1..10] of integer;     input,output: text; begin    assign(input,'input.txt');     assign(output,'output.txt');   reset(input);     rewrite(output);   for i: =1 to 10 do         read(input,a[i]);   for i: =1 to 10 do      begin                if a[i]> 0                      then                           inc(su1,a[i])           else                        inc(su2,a[i]);           end;     writeln(output,'сумма положительных: ',su1);   write(output,'сумма отрицательных: ',su2); close(input); close(output); end.
picsell
Program loto ; uses crt ; const lt = 49; (* количество шаров в лототроне *) shar = 6; (* количество выигрышных шаров*) var lott,vyb : array [1..shar] of integer; i, j, nom, k : integer; m: set of byte; begin randomize; m: =[]; for i: =1 to shar dobeginrepeat nom: =1+random(lt); until not(nom in m) ; lott[i]: =nom; m: =m+[nom]; end; writeln('выберите шаров от 1 до 6 ',lt); m: =[]; beginrepeatwrite('nom',i,'='); readln(nom); until (nom in [1..lt])and not(nom in m); vyb[i]: =nom; m: =m+[nom]; end; clrscr; writeln('номера шаров в лототроне'); for i: =1 to shar do write(lott[i]: 3); writeln; writeln('выбранные шары'); for i: =1 to shar dowrite(vyb[i]: 3); writeln; write('совпавшие шары: '); k: =0; for i: =1 to shar dofor j: =1 to shar do if lott[i]=vyb[j] thenbegin k: =k+1; write(lott[i]: 3); end; if k=0 then write('- нет') else write('   их количество=',k) end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу вычисления стоимости покупки, состоящей из нескольких тетрадей и такого же количества обложек к ним. программа должна запросить цену тетрадей, цену обложек, и их количество вывести стоимость покупки.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

valentinakarma2800
trubchaninova71511
archala
borisrogovpr3407
dimiff5
Андрееевич787
books
sde19755511
Karmelita1978
bb495
martabunova
juliat200520
Vika-simonenko
sonicegle
igevskoemuseumkec
▲