Program r_1; uses crt; const q=pi; var a,b,c: real; begin write('r='); readln(a); write('r='); readln(b); c: =q*(a*a-b*b); writeln('s=',c: 5: 2); readln; end.
merx80
22.04.2020
Если в записи числа присутствует цифра 8, то её основание не может быть меньше 9. в девятиричной системе двух разрядов достаточно для представления числа 88(9)=9х8+8=80(10), поэтому в системе с любым рассматриваемым нами основанием число 32 будет двухзначным. запишем 32 в расширенной форме в системе счисления по основанию n: 32(10)=a x n + b. по условию запись числа оканчивается цифрой 8, т.е. b=8. тогда an+8=32 или an=24. остается решить полученное уравнение в целых числах относительно минимального n≥9: n=24/a разложим 24 на множители: 24 = 2 х 2 х 2 х 3, ⇒ а ∈ (2, 3, 4, 6, 8, 12, 24) a=2 ⇒ n=12 a=3 ⇒ n=8, что уже меньше 9 и большие значения a можно не рассматривать. полагая а=2 и n=12 получаем запись 28 в двенадцатиричной системе. проверка: 28(12)=2х12+8=24+8=32(10). ответ: 12
Alexander2035
22.04.2020
1. первый интервал 21-30, в него входят 10 чисел (21,22,23,24,25,26,27,28,29,30) = а вероятность будет равна количеству чисел этого интервала к общему интервалу [1; 100]. таким образом для первого интервала 10/100 = 10% = 0,1. 2.идем по аналогии с предыдущим интервалом : [31; 55] - это 25 чисел,следовательно 25/100= 25% = 0,25. 3.интервал [25; 100] - это 75 чисел. 75/100= 75%= 0,75. 4. ровно 25, это единственное число,а как вы уже успели заметить - каждое число является 1 процентом. таким образом можно сразу сказать что вероятность для этого случая 1% или 0,01. ответ: 0.1 ; 0.25 ; 0.75 ; 0.01.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу для решения следующей : найти площадь кольца, если заданы радиус внешней окружности и радиус внутренней окружности.