Роман1406
?>

Ввести номер месяца и вывести название времени года. пример: введите номер месяца 4 весна напишите программу на языке паскаль

Информатика

Ответы

dmdlir
Var  a: byte; begin    writeln('введите номер месяца: ');   readln(a);   case a of     1, 2, 12: writeln('зима');     3..5: writeln('весна');     6..8: writeln('лето');     9..11: writeln('осень')   else writeln('ошибка');   end; end.
levsha-27509
4  а) const n=10; var a: array[1..n] of integer; i,k: integer; begin writeln('исходный массив: '); for i: =1 to n do begin a[i]: =random(10); write(' ',a[i]); end; writeln; for i: =1 to n do begin if ((i mod 2) = 0) then a[i]: =a[i]*2 else a[i]: =a[i]*3; end; writeln('конечный массив: '); for i: =1 to n do  write(' ',a[i]); end.б)const n=10; var a: array[1..n] of integer; i,k: integer; beginwriteln('исходный массив: '); for i: =1 to n do begina[i]: =random(10); write(' ',a[i]); end; writeln; for i: =1 to n do beginif ((i mod 2) = 0) thena[i]: =a[i]-a[i]*2; end; writeln('конечный массив: '); for i: =1 to n do  write(' ',a[i]); end.5 a)const n=10; var a: array[1..n] of integer; i,k: integer; begink: =0; writeln('исходный массив: '); for i: =1 to n do begina[i]: =random(10); write(' ',a[i]); end; writeln; for i: =1 to n do beginif (i> 2) and (a[i]> a[i-1]) thenk: =k+1; end; writeln('конечный массив: '); for i: =1 to n do  write(' ',a[i]); writeln; write('кол-во элементов больших соседа слева ',k); end.5 б)const n=10; var a: array[1..n] of integer; z,i,k: integer; begink: =0; z: =0; writeln('исходный массив: '); for i: =1 to n do begina[i]: =random(10); write(' ',a[i]); end; writeln; for i: =1 to n do beginif ((i mod 2) = 0) thenk: =k+1; if k=2 then  begin  k: =0; z: =z+1; end; end; writeln('конечный массив: '); for i: =1 to n do  write(' ',a[i]); writeln; write('кол-во четных пар: ',z); end.6 а)const n=10; var a: array[1..n] of integer; s,k,i: integer; sr: real; begins: =0; k: =0; writeln('исходный массив: '); for i: =1 to n do begina[i]: =random(10); write(' ',a[i]); end; writeln; for i: =1 to n do beginif ((a[i] mod 2) = 0) and ((i mod 2) < > 0) thenbegins: =s+a[i]; k: =k+1; end; end; sr: =s/k; writeln('конечный массив: '); for i: =1 to n do  write(' ',a[i]); writeln; write('среднее арифметическое четных элементов с нечетными индексами: ',sr); end.
zhunina71807
#include < iostream> using std: : cout; using std: : cin; using std: : endl; int biggest(int, int); //функция нахождения большего из 2-ух чисел int main() {     int a, b, c;     cout < < "enter the three numbers: ";     cin > > a > > b > > c;     cout < < "biggest: " < < biggest(biggest(a, b), c) < < endl;     cin.get();     return 0; } int biggest(int x, int y) {     if(x > y)     {         return x;     }     else         return y; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ввести номер месяца и вывести название времени года. пример: введите номер месяца 4 весна напишите программу на языке паскаль
Ваше имя (никнейм)*
Email*
Комментарий*