vainshakov
?>

Решите : 1) составьте программу ввода элементов массива [1..8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями.2) составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с четными значениями.3) составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями и количество элементов с нечетными значениями.4) составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. выведите на экран исходный и полученный массивы.

Информатика

Ответы

info-mosbalkon
1) uses crt; const n=8; var i: integer; a: array[1..n] of integer; begin writeln('input elements.'); for i: =1 to n do read(a[i]); for i: =1 to n do if a[i]< 0 then write(a[i],' '); end.2)uses crt; const n=10; var i,t: integer; a: array[1..n] of integer; beginrandomize; t: =0; write('массив: '); for i: =1 to n dobegina[i]: =random(10,1); write(a[i],' '); if a[i] mod 2=0 thent: =t+1; end; writeln(#13#10,t); end.3)uses crt; const n=10; var i,sum,t: integer; a: array[1..n] of integer; beginrandomize; sum: =0; t: =0; write('массив: '); for i: =1 to n dobegina[i]: =random(10,1); write(a[i],' '); if a[i] mod 2=0 thensum: =sum+a[i]elset: =t+1; end; writeln(#13#10,sum,' ',t); end.4)uses crt; const n=10; var i: integer; a: array[1..n] of integer; beginrandomize; for i: =1 to n dobegina[i]: =random(10,1); write(a[i],' '); if a[i] mod 2=0 thena[i]: =2*a[i]elsea[i]: =3*a[i]; end; write(#13#10); for i: =1 to n dowrite(a[i],' '); end.
Pashinov

1. какой тег применяется для определения нового абзаца? ответ: 2. какие теги могут не содержать закрывающийся эквивалент (конечный тег): a) < p> ; b) < br> ; +c) < h2> ; d) < a> .3. выберите функцию, выполняемую тегом < b> : a) выделение полужирным; +b) увеличение кегля символов; c) выделение курсивом; d) уменьшение кегля символов.4. выберите все значения, которые может принимать атрибут align в теге < img> : a) left; +b) right; +c) center; +d) top.5. следующий html-код: < font color=”red”> < font color=”black”> книга< /font> < /font> . какой цвет будет использоваться для отображения слова «книга» в браузере? ответ: вывело зеленый цвет.. 6. во внешней таблице стилей создана следующая запись: h3 {color: green; }.как будет отображаться документ в браузере, к которому она применена? a) каждый заголовок, заключённый в тег < h3> , будет выделен зелёным цветом; +b) каждый заголовок, заключённый в тег < h3> , будет выделен зелёным полужирным шрифтом; c) каждый заголовок, заключённый в тег < h3> , будет выделен полужирным шрифтом и выровнен по центру.7. внутри какого тега помещается тег < title> ? указать открывающий и закрывающий теги с использованием угловых скобок.ответ: < head> 8. внутри какого тега должен стоять атрибут align, чтобы происходило выравнивание содержимого ячейки таблицы? a) < td> ; +b) < tr> ; c) < table> .9. какой из нижеперечисленных атрибутов является обязательным для тега < a> ? a) href; +b) target; c) class.10. какие функции выполняет атрибут size тега < font> : a) определяет размер символов; +b) определяет цвет символов; c) определяет гарнитуру символов; d) определяет выравнивание текста относительно страницы.

nadlen76

1.

2-й игрок получает информацию о том, на какую клетку походил первый. так как это уже третий ход первого, значит перед этим были заняты 4 клетки (два хода первого + два хода второго). это значит, что перед 3-м ходом первого свободны 25 - 4 = 21 клетка. для кодирования информации об одной из 21 клеток нужно 5 бит (решаем неравенство n< =2^i, подбирая минимально возможное значение i)ответ: 5 бит

2.

1/512 мбайт = (1024/512) кбайт = 2 кбайт = 2048 байтвсего 2048 символов, значит, для кодировки одного символа нужен 1 байт .1 байт = 8 битс 8 бит можно закодировать 2^8=256 символовответ: размер алфавита 256 символов

3.

для кодировки каждого символа 16-символьного алфавита нужно 4 бит(решаем неравенство 16< =2^i, подбирая минимально возможное значение i). далее, одна страница текста содержит 30 * 50 = 1500 символов.6 страниц текста содержат 6 * 1500 = 9000 символов.весь текст содержит 9000 символов * 4 бит = 36000 бит = 4500 байт (приблизительно 4,39 кбайт)

ответ: 4500 байт

 

примеры:

  - система автоматической терморегуляции поддерживает заданную температуру ( устройство получает информацию от температурных датчиков, обрабатывает ее - сравнивает реальную температуру с заданной, и передает команды нагревательному элементу - усилить или уменьшить нагрев) - например в кондиционерах  - система программного обеспечивают стирку в стиральной машине в заданном режиме  - система записи звука в диктофоне  - система станком с чпу (числовым программным )

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите : 1) составьте программу ввода элементов массива [1..8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями.2) составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с четными значениями.3) составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями и количество элементов с нечетными значениями.4) составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. выведите на экран исходный и полученный массивы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

родичева1812
tanu0618
DmitrievnaVera
ars-trushakova
intermar2000
lavr74
Елена
vodolaz8384
fixer2006
egoryandiana3727283
yurievaalxndra55
alf206
Sergeevna-Makarov
d2904
school24mir23
▲