superniki87
?>

Сделать в паскале. составьте программу, которая удаляет из слова x те буквы, которые встречаются в слове z. слова x и z вводятся с клавиатуры.

Информатика

Ответы

vladimir72tatarkov1317
Var x,z: string; i: integer; ar: array['а'..'я'] of boolean; begin readln(x); readln(z); for i: =1 to length(z) do   ar[z[i]]: =true;     for i: =length(x) downto 1 do       if (ar[x[i]] = true) then delete(x,i-1,1);       writeln(x); end.не забудь отметить лучший ответ ; -)
gena1981007
// javascript var getindexesofarrayinlimits = function (array, minvalue, maxvalue){     var isinlimit = function (value) {         return value > = minvalue & & value < = maxvalue;     }     var getindexesofarraylimitedbyfunc = function (array, func) {         var results = [];         array.foreach(function(element, index, array) {             if ((element)) {                 results.push(index);             }         });         return results;     }     return getindexesofarraylimitedbyfunc(array, isinlimit); } // that's an example of using the functiongetindexesofarrayinlimits([1, 5, 2, 3, 4], 1, 3);
Aleksandr740
Давайте сделаем так: опишем 4 функции в программе. когда надо - вытащим   ок? uses crt; var x1, x2 , dx, y: real;       i: integer; function f1 (x: real): real;   begin     f1: =2*x; end; function f2 (x: real): real;   begin     f2: =x/3+9;   end; function f3 (x: real): real; begin   f3: =x-4; end; function f4 (x: real): real; begin   f4: =x/8-6; end; begin clrscr; write(' x1 = '); readln(x1); write(' x2 = '); readln(x2); write (' dx = '); readln(dx); i: =1; repeat     writeln(f1(i): 6: 3);     i: =i+1; until i> x2; readln; end. например, задавая х1= -10                                 х2= 10                                 dx = 1  получаем значения для первой функции записав writeln (f3(i): 6: 3); - получаем значения для третьей функции и так

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сделать в паскале. составьте программу, которая удаляет из слова x те буквы, которые встречаются в слове z. слова x и z вводятся с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*