rpforma71189
?>

Составить программу тест по биологии, тестовые вопросы с вариантами ответов, и выставляющий оценку, в зависимости от количества правильных ответов.

Информатика

Ответы

snezhanaklimenkova

Код:

using System;

namespace WordsCounter

{

   class Bishop

   {

       private int x, y;

       public Bishop(int x, int y)

       {

           this.x = x;

           this.y = y;

       }

       public bool CanIAttackIt(int x, int y)

       {

           return Math.Abs(x - y) == Math.Abs(this.x - this.y);

       }

   }

   class Program

   {

       static void Main(string[] args)

       {

           var x0 = int.Parse(Console.ReadLine()!);

           var y0 = int.Parse(Console.ReadLine()!);

           var x = int.Parse(Console.ReadLine()!);

           var y = int.Parse(Console.ReadLine()!);

           Console.WriteLine((new Bishop(x0, y0)).CanIAttackIt(x, y));

       }

   }

}


На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
Natalya

АБВГ

Объяснение:

1. Переведем символы в логические операции:

А Рататуй или Рапунцель или Зверополис

Б (Рататуй и Рапунцель) или Зверополис

В Рататуй и Рапунцель

Г Рататуй и Рапунцель и Зверополис

2. Наибольшее количество страниц будет при за с "или", так как

операция "и" "ограничивает" поиск, то есть при поиске "Рататуй ИЛИ Рапунцель" мы будем видеть следующие страницы:

-Рататуй

-Рапунцель

-Рататуй и Рапунцель,

а при поиске "Рататуй И Рапунцель" появятся следующие результаты:

-Рататуй и Рапунцель.

Таким образом, наибольшее число страниц мы получим при за А: Рататуй | Рапунцель | Зверополис, наименьшее - Г: Рататуй & Рапунцель & Зверополис.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу тест по биологии, тестовые вопросы с вариантами ответов, и выставляющий оценку, в зависимости от количества правильных ответов.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ars-trushakova
nikitavertiev98400
Vyacheslavovna1108
olegmgu1
лукашова940
tata-novik
derkachn6429
Nikita
smakejkina
maxim-xx38
ganul
zbellatriks
Struev730
julya847
xarchopuri22
▲