laplena1982750
?>

Составить программу поиска больших чем соседние элементов массива l из 16 чисел. значения элементов массива рассчитать по формуле cosd/d, где d номер элемента массива.

Информатика

Ответы

antongenfon
Var       i: integer;     a: array [1..16] of real; begin     for i : = 1 to 16 do begin         a[i] : = cos(i) / i;         writeln('l[',i,'] = ',a[i]); end;     writeln;     for i : = 2 to 15 do         if (a[i] > a[i-1])and(a[i] > a[i+1]) then writeln('l[',i,'] = ',a[i]); end.
Nikolaevna1623

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           double a, b, c;

           Console.WriteLine("Введите a:");

           a = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите b:");

           b = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите c:");

           c = Convert.ToDouble(Console.ReadLine());

           Console.Write("Результат: {0} , {1}, {2}", (a > 0) ? a * a : a * a * a * a,

               (b > 0) ? b * b : b * b * b * b, (c > 0) ? c * c : c * c * c * c);

       }

   }

}

drontox1031

Переводим третий байт IP и адреса сети в двоичную систему

50 - 110010

48 - 110000

Так как это байт (а в байте 8 бит), допишем два незначащих нуля к получившимся числам:

00110010 - IP

00110000 - адрес сети

Адрес сети получается с применения поразрядной конъюнкции к маске и IP, проще говоря, при перемножении разрядов маски и IP-адреса. И в маске всегда сначала идут только единицы, а потом только нули. То есть можно записать так:

хххххххх - маска

00110010 - IP

00110000 - адрес сети

где иксы в маске и цифры в IP-адресе - множители, а разряды адреса сети - произведение.

На 3 и 4 месте в маске однозначно должны быть единицы, т.к. если там будут нули, то и в адресе сети будут нули. Плюс к этому, в маске всегда сначала идут только единицы, а потом только нули, то есть можно записать так:

1111хххх - маска

00110010 - IP

00110000 - адрес сети

Второй справа разряд IP-адреса - единица, а адреса сети - ноль, значит в маске может быть только ноль:

1111хх00 - маска

00110010 - IP

00110000 - адрес сети

Оставшиеся два икса могут быть и единицами, и нулями. Нужно наименьшее возможное значение, значит поставим на их место нули:

11110000 - маска

00110010 - IP

00110000 - адрес сети

То есть третий байт маски 11110000, переведём в десятичную - получим 240.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу поиска больших чем соседние элементов массива l из 16 чисел. значения элементов массива рассчитать по формуле cosd/d, где d номер элемента массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Татьяна-Мишин1307
fedserv
Екатерина
saltikovaPavlenko
zybin41iz81
Andrei Morozov
Romanovna-yana
Anastasiya
yuliyastatsenko3894
slonikkristi69
kristina
vasiliyglukhov
Yurok9872
Екатерина1979
egorstebenev6