gena1981007
?>

Pascal abc составить программу через array и for подсчитайте количество морозных дней (когда температура ниже -20

Информатика

Ответы

Tatyana_Minullina
Var       i, kol: integer;       a: array [1..20] of integer; begin       for i : = 1 to 20 do read(a[i]);       for i : = 1 to 20 do             if (a[i] < -20) then inc(kol);       write(kol); end.
ivnivas2008
№1 60 мбайт * 8 = 480 мбит - размер файла в мегабитах 480 мбит * 1024 = 491520 кбит - размер файла в килобитах 491520 / 2 = 245760 кбит - половина файла 245760 кбит / 256 = 960 секунд - время передачи первой половины файла 245760 кбит / (256 / 2) = 245760 кбит / 128 = 1920 секунд - время передачи втораой половины файла 960 с + 1920 с = 2880 секунд - общее время передачи в одной минуте 60 секунд: 2880 / 60 = 48 минут - передан весь файл №2 переведем килобайты в биты: n = 3750кбайт = 30720000бит вычислим скорость передачи информации: v = 30720000/120 v = 256000 бит/c
Sharap
Ну, в общем, лови решение. { freepascal 2.6.4} program test; uses       crt; var       a, b, c, d  : integer;       f : longint; procedure swap (var x : integer; var y : integer); var z : integer; begin       z : = x;       x : = y;       y : = z; end; function nod (m, n : integer) : integer; begin       while m< > n do begin               if m> n               then                       m: =m-n               else                       n: =n-m;       end;       nod : = m; end; function max (a,b : integer) : integer; begin       if a> b       then max : = a       else max : = b; end; function min (x, y, z : integer) : integer; var m : integer; begin       m : = x;       if y< m then m : = y;       if z< m then m : = z;       min : = m; end; function mypow (a, b : integer) : integer; var e, f : integer; begin       f : = 1;       for e: =1 to b do f : = f*a;       mypow : = f; end; function fact(a : integer) : longint; var       i : integer;       res : longint; begin       res : = 1;       for i : = 1 to a do res : = res*i;       fact : = res; end; begin       clrscr;       writeln('test of function swap');       write('input a: ');       readln(a);       write('input b: ');       readln(b);       swap(a, b);       writeln('a=', a, ', b=', b);       writeln;       writeln('test of function nod');       write('input a: ');       readln(a);       write('input b: ');       readln(b);       c : = nod(a, b);       writeln('nod(', a, ',', b, ')=', c);       writeln;       writeln('test of function max');       write('input a: ');       readln(a);       write('input b: ');       readln(b);       c : = max(a, b);       writeln('max(', a, ',', b, ')=', c);       writeln;       writeln('test of function min');       write('input a: ');       readln(a);       write('input b: ');       readln(b);       write('input c: ');       readln(c);       d : = min(a, b, c);       writeln('min(', a, ',', b, ',', c, ')=', d);       writeln;       writeln('test of function pow');       write('input a: ');       readln(a);       write('input b: ');       readln(b);       c : = mypow(a, b);       writeln('pow(', a, ',', b, ')=', c);       writeln;       writeln ('test of function fact (not large than 12! )');       write('input a: ');       readln(a);       f : = fact(a);       writeln(a, '! =', f);       writeln;       readkey; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal abc составить программу через array и for подсчитайте количество морозных дней (когда температура ниже -20
Ваше имя (никнейм)*
Email*
Комментарий*