abramovae
?>

Написать программу, которая считывает текст из файла и выводит его на экран, после каждого предложения добавляя, сколько раз встретилось в нем введённое с клавиатуры слово.

Информатика

Ответы

Kubataeva Nikolaevich1389
1const n=30; var a: array [1..n] of integer; i,j,s: integer; begin for i: =1 to n do readln(a[i]); for i: =1 to n do if (a[i]> 99)and(a[i]< 1000) then if (a[i] mod 2)< > 0 then begin s: =s+a[i]; j: =j+1; end; if j=0 then writeln('в массиве нет нечётных трехзначных чисел') else writeln('среднее арифметическое нечётных трехзначных чисел: ',s/j); end. 2 const n=40; var a: array [1..n] of integer; i,x,y: integer; s: real; begin for i: =1 to n do readln(a[i]); x: =abs(a[1]); for i: =1 to n do if (a[i]> 0)and((a[i] mod x)=0) then begin y: =y+1; s: =s+a[i]; end; if y=0 then writeln('в массиве нет нечётных трехзначных чисел') else writeln('среднее арифметическое положительных чисел кратных первому элементу: ',s/y); end. 3 const n=30; var a: array [1..n] of integer; i,s,m: integer; begin for i: =1 to n do readln(a[i]); m: =a[1]; for i: =2 to n do if a[i]> m then m: =a[i]; for i: =1 to n do if a[i]=m then s: =s+1; if s=1 then writeln('в массиве только один максимальный элемент') else writeln('число элементов, равных максимальному: ',s-1); end.
melissa-80

n = int(input('n? '))

l = [[0 for j in range(n)] for i in range(n)]

n = n*n

i = 0

j = 0

k = 1

while k < = n:

    l[i][j] = k

    if i < = j + 1 and i + j < n - 1:  

        j += 1

    elif i < j and i + j > = n-1:  

        i += 1

    elif i > = j and i + j > n-1:  

        j -= 1

    else:  

        i -= 1

    k += 1

 

 

for i in l:

    print(*i,sep='\t')

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая считывает текст из файла и выводит его на экран, после каждого предложения добавляя, сколько раз встретилось в нем введённое с клавиатуры слово.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pisikak999
mez-omts-d5
mamaevmvv3
alenchik19938823
Savva1779
misie1974
Shago
ntyremsk1
mariya
vera4
retropluse832
Никита_Тузов
Yurevna
An-solomon
vikgor45