AlidzhanovDenis491
?>

Записать алгоритм и написать программу циклического перемещения влево значений между переменными а, b, c

Информатика

Ответы

Dmitrii836
Program gt; var a,b,c,k: integer; begin read(k); {k-на какое число шагов надо переместит числа a  b  c влево} k: =k mod 3; if(k=0)then writeln(a,' ',b,' ',c); if(k=1)then writeln(b,' ',c,' ',a); if(k=2)then writeln(c,' ',a,' ',b); end.
Оздоевский
1var x,y: integer; begin   writeln('введите х');   readln(x);   writeln('введите y');   readln(y);   if x< y then writeln('меньшее: ',x) else   if x> y then writeln('меньшее: ',y) else   if x=y then writeln('числа равны') end. 2 var x,y: integer; begin   writeln('введите первое число');   readln(x);   writeln('введите второе число');   readln(y);   if y=0 then writeln('второе число равно 0. деление невозможно! ') else   writeln(x,'/',y,'=',x/y); end. 3 var s,name: string; begin   writeln('введите ваше имя');   readln(name);   writeln('введите строку');   readln(s);   if s=name then writeln('! ') else   writeln('! '); end. 4 var x: integer; begin   writeln('введите число');   readln(x);   if (x mod 2)=0 then writeln('четное') else writeln('нечетное') end. 5 var x: string; i: integer; begin   writeln('введите строку');   readln(x);   writeln('введите номер символа');   readln(i);   if i > length(x) then writeln('нет символа! ') else writeln(x[i]) end. 6 var x,y: integer; begin   writeln('количество яблок: ');   readln(x);   writeln('количество апельсинов: ');   readln(y);   if (x*100)> (y*150) then writeln('берите яблоки')   else   if (x*100)< (y*150) then writeln('берите апельсины')   else   if (x*100)=(y*150) then writeln('вес яблок и апельсинов одинаковый') end.
keti0290103
Если смотреть с точки зрения паскаля, то получается такая ересь: var x,z,c,y: real; begin writeln('введите  первое  число'); readln(x); writeln('введите второе число'); readln(z); q: =x-y; (разность первого и последнего  числа); w: =z+c; (сумма второго и третьего числа); в случае если выполняются эти два условия if q > z then if w < y then  begin  writeln(w); writeln(z); end else  if q > z then writeln(z)  else if  w < y then writeln(w); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Записать алгоритм и написать программу циклического перемещения влево значений между переменными а, b, c
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Суравцова_Алексей669
igortychinin
sashakrotova943
NatalyaAlekseevich1644
Tipan77
artem032100
tarja4140
maltes
pristav9
s45983765471717
guzelda19904850
evge-borisova2
Volkovapavel
Alekseevna1064
joini09