Роман1406
?>

По заданному числу n от 1 до 365 определите, на какое число какого месяца приходится день невисокосного года с номером n. программа получает на вход целое число n и должна вывести два числа: число месяца (от 1 до 31) и номер месяца (от 1 до 12), на которое приходится данный день.

Информатика

Ответы

Анатольевич447
Program gt; label 1; var n,i,s: integer; begin readln(n); s: =0; for i: =1 to 12 do begin if(i=1)or(i=3)or(i=5)or(i=7)or(i=8)or(i=10)or(i=12)then begin s: =s+31; if(n< =s)then begin writeln(n-s+31,' ',i); goto 1; end; end; if(i=2)then begin s: =s+28; if(n< =s)then begin writeln(n-s+28,' ',i); goto 1; end; end; if(i=4)or(i=6)or(i=9)or(i=11)then begin s: =s+30; if(n< =s)then begin writeln(n-s+31,' ',i); goto 1; end; end; end; 1: end.
silicon-films3375
1. с=2*pi*r, s= pi*r^2, v=4/3*pi*r^3, где pi=3,14, заданный радиус r 2. p=a+b, s=1/2*a*b, где a и b - данные катеты 3. пусть даны координаты трех вершин треугольника a(x1; y1), b(x2; y2), c(x3; y3). расстояние между двумя точками вычисляется по формуле тогда периметр треугольника можно вычислить по формуле: p=sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2). площадь треугольника по формуле герона вычисляется по формуле: , где -полу периметр треугольника. s=sqrt((sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x2-x1)^2+(y2-y1)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-+sqrt((x3-x2)^2+(y3-y2)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x3-x1)^2+(y3-y1)^2)) 4. среднее трех чисел вычисляется по формуле или (a*b*c)^1/3
KononovaMaiorov453
Граф,  графи́ня  (нем.  graf)  —  королевское  должностное лицо в  раннем средневековье  в  западной европе.  титул  возник в  iv веке  в  римской империи  и первоначально присваивался высшим  сановникам(например,  comes sacrarum largitionum  «главный казначей»). во  франкском государстве  со второй половины  vi века  граф (гауграф) в своём  округе-графстве/гау(нем.  gau  — первоначально, сельская община у древних германцев, численностью ок. 100 человек) обладал судебной, административной и военной властью.  по постановлению  карла ii лысого  (877)  должность  и владения графа стали наследственными. в период  феодальной раздробленности  —  феодальныйвладетель  графства, затем (с ликвидацией феодальной раздробленности) титул высшего  дворянства. в качестве титула формально продолжает сохраняться в большинстве стран европы с  монархической  формой правления. в  россии  титул введён  петром i(первым его получил в 1706 году  б.  п.  шереметев). в конце  xix векаучтено свыше 300 графских родов. графский титул в советской россии был ликвидирован декретом  вцик  и  совнаркома  от  11 ноября  1917 года.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

По заданному числу n от 1 до 365 определите, на какое число какого месяца приходится день невисокосного года с номером n. программа получает на вход целое число n и должна вывести два числа: число месяца (от 1 до 31) и номер месяца (от 1 до 12), на которое приходится данный день.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

btatarintsev
Анатольевич447
katarinacorvus825
Шавкат кызы
annabanova9
demon8608
lbeglarova6
srvsm
akremlev2015
buhh20104519
galereyaas1568
Aleksandrovna-Marina
mrilyushchenko6
Serkova_Elena251
andre6807