Program gt; var a: array[1..6]of integer; i,s: integer; begin randomize; s: =0; for i: =1 to 6 do begin a[i]: =random(101)+20; write(a[i],' '); s: =s+a[i]; end; writeln; writeln(s); end.
md-masya
20.09.2022
Const n=30; var a: array[1..n] of integer; i: integer; begin randomize; writeln('исходный массив: '); for i: =1 to n do begin a[i]: =random(9000)+1000; write(a[i]: 5); end; writeln; for i: =1 to n do if a[i] mod i = 0 then a[i]: =1 else a[i]: =0; writeln('полученный массив: '); for i: =1 to n do write(a[i],' '); writeln; end. пример (для n=10): исходный массив: 2309 2867 6032 7114 7552 6798 8799 3607 2014 2876 полученный массив: 1 0 0 0 0 1 1 0 0 0
zubov-073620
20.09.2022
1) 16=2^4 4 бита - информационный объём одной их различных конфет 2) 8=2^3 --> 3 бита для кодирования одногосимвола 20*3= 60 бит информационный объём сообщения 3) 4096 : 1024= 4 бита один символ 2^4 = 16 символов в алфавите 4) 32 =2^5 --> 5 бит для кодировки одного символа 4*64*16*5=5*2^2 * 2^6 * 2^4 =5*2^ (12) бит = 5*2^9 байт= = 5*512 байт = 2560 байт = 2,5 кбайт
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу, которая создает массив из 6 случайных чисел, принадлежащих [20; 120] и вычисляет сумму элементов этого массива.