avtalux527
?>

Много ! напишите программу как в паскале для : 1. с клавиатуры вводят координаты точки, не лежащей на координатных осях ох и oy. определить номер координатной четверти, в которой находится данная точка. 2. с клавиатуры вводятся четыре числа. найти сумму наибольшего с наименьшим.

Информатика

Ответы

libirishka7910

Объяснение:

1) program abc;

var x,y:real;

begin

readln(x,y);

if (x>0) then begin // проверка по x

 if (y>0) then  

  writeln('1th'); // попадает в первую

 if (y<0) then

   writeln('4th'); // проверка в четвёртую

end

else begin

 if (y>0) then  

  writeln('2nd'); // попадает во вторую

 if (y<0) then

  writeln('3th'); // попадает в третью

end;

end.

2)

program abc;

var A:array [1..4] of real; // ввод массива из четырёх чисел

i,max,min:shortint; // i - цикл, max - индекс максимального значения, min - минимального

s:real; // сумма

begin

readln(a[1]); // ввод первого значения

max:=1;

min:=1; // считаем что первое значение и минимум и максимум

for i:=2 to 4 do

 begin

  readln(A[i]); // ввод массива

  if A[i]>a[max] then // Если данный элемент больше максимального

   max:=i; // То записываем индекс этого элемента

 if A[i]<A[min] then // аналогично с минимумом

 min:=i;

 end;

s:=A[max]+a[min]; // суммируем и выводим

write(s);

 end.

Mariya694

Абзац– это основная структурная единица текстового процессора. Абзац – это структурный элемент текстового файла или текстового документа, представляющий собой, по мнению автора текста, законченный по смыслу фрагмент изложения. При наборе текста разбиение на абзацы производится в соответствии с содержанием (по смыслу текста). С точки зрения компьютера (текстового процессора), абзац подразделяется на символы.

Символ– минимальная единица текстовой информации. Символы – это буквы, пробелы, знаки пунктуации, цифры, специальные символы (@, *, &).

morozov1605
Совершенным называется число, равное сумме всех своих делителей (включая 1, но исключая само число). Наименьшее из совершенных чисел 6 равно сумме трех своих делителей 1, 2 и 3.
1.
var n,s,i,j:integer;
begin
write('n = ');
readln(n);
for i:=2 to n do
 begin
 s:=1;
 for j:=2 to i div 2 do
  if i mod j = 0 then s:=s+j;
 if s=i then write(i,' ');
 end;
end.

Пример:
n = 1000
6 28 496 

2.
алг Числа
нач 
  цел n,s,i,j
  вывод "n =", нс
  ввод n
  нц для i от 2 до n
    s:=1
    нц для j от 2 до div(i,2)
     если mod(i,j) = 0 то
      s:=s+j
     все
    кц
    если s = i то
      вывод i, нс
    все
  кц
кон

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Много ! напишите программу как в паскале для : 1. с клавиатуры вводят координаты точки, не лежащей на координатных осях ох и oy. определить номер координатной четверти, в которой находится данная точка. 2. с клавиатуры вводятся четыре числа. найти сумму наибольшего с наименьшим.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

plv-57
Advantage9111
fomindmity1
marinarodina90
info49
nsmirnova
mishink535
mushatolga
mitin228133770
doorhan42n6868
cetarbkilork82
мария Кузив1393
Olga1233
most315
Avetisyan575