nekataniyoleg
?>

Напишите следующую программу. введите с клавиатуры целое число n. выведите на экран числа от 1 до n так, чтобы каждое число выводилось столько раз, каково его значение. например, если с клавиатуры введено 6, то на экране мы должны увидеть: 1 2 2 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6 написать программу нужно как можно проще в программе pascalabc

Информатика

Ответы

guzelda19904850
Вообщем, сделал , но метод пузырька уже не выйдет : ) т.е. сортировка по возрастанию : ( как мог. program asd; uses crt; var n,m,i,j: integer; begin clrscr; writeln('введите число n: '); readln(n); n: =n+1; for i: =1 to n do    begin  n: =n-1;       for j: =1 to n   do          begin            write(n: 3);         end;   end; end.
krasnobaevdj3
Получается интересная картина. я руками за 5 дней делаю 5 коробок, и на 6-ой день покупаю духовку. руками и духовкой я делаю 2 коробки в день, за 5 дней - 10 коробок. на 6-ой день я покупаю вторую духовку. руками и 2-мя духовками я за 5 дней делаю 15 коробок, и на 6-ой день покупаю 3-ью духовку. и так далее. чтобы купить очередную духовку, я работаю 5 дней, а на 6-ой день ее покупаю, и у меня печенья не остается совсем. то есть, после покупки каждой духовки я начинаю всё с нуля. главное - понять, когда нужно остановиться покупать духовки и начать уже копить печенье на складе. итак, подведем итоги: 1) на покупку каждой духовки мы тратим 6 суток и начинаем с нуля. 2) имея n духовок, мы делаем 556 коробок печенья за trunc(556/(n+1)) + 1 дней, где trunc(x) = [x] - это целая часть x. 3) всего мы тратим времени t(n) = 6n + trunc(556/(n+1)) + 1 --> min минимум функции trunc(556/(n+1)) совпадает с минимумом 556/(n+1) t(n) = 6n + 556/(n+1) + 1 --> min t'(n) = 6 - 556/(n+1)^2 = (6(n+1)^2 - 556) / (n+1)^2 = 0 6(n+1)^2 - 556 = 0 6n^2 + 12n + 6 - 556 = 0 3n^2 + 6n - 275 = 0 d = 36 - 4*3(-275) = 36 + 3300 = 3336 ~ 57,7^2 n1 = (-6 - 57,7)/6 < 0 - не подходит n2 = (-6 + 57,7)/6 ~ 8,6 = 9 значит, нужно ограничиться покупкой 9 духовок. за 6*9 = 54 дня мы их купим, и за 556/10 ~ 56 дней мы соберем нужное количество коробок на складе. всего мы истратим 54 + 56 = 110 дней.
re22no22
// pascalabc.net 3.1, сборка 1179 от 29.02.2016 function isprime(n: integer): boolean; begin   result: =range(2,round(sqrt((i-> n mod i< > 0) end; begin   var n: =9;   var a: =matrixrandom(n,n,3,15);   var k: =0;   for var i: =0 to n-1 do begin       for var j: =0 to n-1 do begin           write(a[i,j]: 3);           if isprime(a[i,j]) then inc(k)           end;       writeln       end;   writeln('простых чисел: ',k) end. тестовое решение:   12 15 13  5  8  5 11 14  9   7  7 14 10  5 10  9 12  3   8  8 10  7 12 14  7  6  9   13 13  7  6  4  9 13 10 11   15  4 11 12 11  4 12  8  9   7  6 14  5 10 15  6  7  9   4  7  6 14 13  5 11 13  3   4  4  5  7 12 10 14  9 11   7 12 13  8 10  6  8  3 15 простых чисел: 32

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите следующую программу. введите с клавиатуры целое число n. выведите на экран числа от 1 до n так, чтобы каждое число выводилось столько раз, каково его значение. например, если с клавиатуры введено 6, то на экране мы должны увидеть: 1 2 2 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6 написать программу нужно как можно проще в программе pascalabc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

coffee2201
matveevaev81
sveta740450
printlublino
Karina-evgenevna1899
daverkieva568
evada2
msangelika1010
Николаевич-Золотая832
Apresov
Alekseeva_Khlistov
moidela87
Makarov
semenoffufc8
Константин Андрей
▲