sergeychelyshev197618
?>

Решить с паскаля две : 1. составить программу, которая содержит функцию и которая определяет, верно ли, что сумма цифр числа является четным числом. 2. составить программу, которая определяет, верно ли, что в заданном числе все цифры стоят по возрастанию.

Информатика

Ответы

svetlanam81
Program gt; var n: integer; function chik(n: integer): integer; var s,q: integer; begin s: =0; while n> 0 do begin q: =n mod 10; n: =n div 10; s: =s+q; end; chik: =s; end; begin read(n); if(chik(n) mod 2=0)then writeln('yes')else writeln('no'); end.2)program gt; var n,q,k,r: integer; beginread(n); k: =0; r: =-1; while n> 0 dobeginq: =n mod 10; n: =n div 10; if(q> =r)and(r< > -1)then k: =1; r: =q; end; if(k=0)then writeln('yes')else writeln('no'); end.
askorikova

ответ:

объяснение:

t     i     m   e

54 69 6d 65

01010100₂ - t

01101001₂ - i

01101101₂ - m

01100101₂ - e

54₁₆ = 4*16⁰ + 5*16¹ = 84₁₀

84₁₀ = 0*2⁰ + 0*2¹ + 1*2² + 0*2³ + 1*2⁴ + 0*2⁵ + 1*2⁶ = 1010100₂

69₁₆ = 9*16⁰ + 6*16¹ = 105₁₀

105₁₀ = 1*2⁰ + 0*2¹ + 0*2² + 1*2³ + 0*2⁴ + 1*2⁵ + 1*2⁶ = 1101001₂

6d₁₆ = d*16⁰ + 6*16¹ = 109₁₀

109₁₀ = 1*2⁰ + 0*2¹ + 1*2² + 1*2³ + 0*2⁴ + 1*2⁵ + 1*2⁶ = 1101101₂

65₁₆ = 5*16⁰ + 6*16¹ = 101₁₀

101₁₀ = 1*2⁰ + 0*2¹ + 1*2² + 0*2³ + 0*2⁴ + 1*2⁵ + 1*2⁶ = 1100101₂

РостиславовичЮлия1147

ответ:

объяснение:

t     i     m   e

54 69 6d 65

01010100₂ - t

01101001₂ - i

01101101₂ - m

01100101₂ - e

54₁₆ = 4*16⁰ + 5*16¹ = 84₁₀

84₁₀ = 0*2⁰ + 0*2¹ + 1*2² + 0*2³ + 1*2⁴ + 0*2⁵ + 1*2⁶ = 1010100₂

69₁₆ = 9*16⁰ + 6*16¹ = 105₁₀

105₁₀ = 1*2⁰ + 0*2¹ + 0*2² + 1*2³ + 0*2⁴ + 1*2⁵ + 1*2⁶ = 1101001₂

6d₁₆ = d*16⁰ + 6*16¹ = 109₁₀

109₁₀ = 1*2⁰ + 0*2¹ + 1*2² + 1*2³ + 0*2⁴ + 1*2⁵ + 1*2⁶ = 1101101₂

65₁₆ = 5*16⁰ + 6*16¹ = 101₁₀

101₁₀ = 1*2⁰ + 0*2¹ + 1*2² + 0*2³ + 0*2⁴ + 1*2⁵ + 1*2⁶ = 1100101₂

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить с паскаля две : 1. составить программу, которая содержит функцию и которая определяет, верно ли, что сумма цифр числа является четным числом. 2. составить программу, которая определяет, верно ли, что в заданном числе все цифры стоят по возрастанию.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

marim1994361
Melnik Kaveshnikova1746
slitex
elenaperemena8
sarbaevmax
Varvara
borisova-valeriya
tolyan791
rusdtver
yana799707
Стадник620
yatania-popovich7
Владимир
opscosmiclatte7868
izumrud153