Даны две веревки а и в, а длинная в короткая нужно вычислить сколько раз в входит в а и остаток х который не вошел? решить не используя деления и умножения.составить программу по паскалю
Uses crt; var a,b,ans,x: real; begin writeln('введите длины веревок a b: '); read(a,b); while a> =b do begin a: =a-b; ans: =ans+1; end; x: =a; writeln('ответ: ',ans); writeln('остаток: ',x); end.
sashakrotova943
29.09.2020
№1 // pascalabc.net 3.1, сборка 1239 от 08.05.2016 begin var a: =arrrandom(31,-20,20); a.println; writeln('средняя температура в оттепели: ', a.where(x-> x> 0).average: 0: 1,' град.') end. тестовое решение 7 -9 -18 -8 14 -2 12 13 4 -18 13 -6 -8 6 -10 -8 20 -15 15 -2 17 20 19 -1 16 10 -7 9 -15 20 -20 средняя температура в оттепели: 13.4 град. №2 // pascalabc.net 3.1, сборка 1239 от 08.05.2016 // также проверено в wde: begin var x: =arrrandom(readinteger('m='),1,99); x.println; var sn: =x.where((x,i)-> i.iseven).sum; var i: =1; while i< x.length do begin x[i]: =sn; inc(i,2) end; x.println end. тестовое решение m= 15 26 31 19 99 3 93 64 31 97 14 88 88 81 49 43 26 421 19 421 3 421 64 421 97 421 88 421 81 421 43
Viktorovna_Yurevna
29.09.2020
1) const n=31; var a: array[1..n] of integer; i,s,k: integer; begin randomize; for i: =1 to n do begin a[i]: =random(41)-20; write(a[i]: 4); end; writeln; s: =0; k: =0; for i: =1 to n do if a[i]> 0 then begin s: =s+a[i]; k: =k+1; end; writeln('средняя температура дней с оттепелью = ',s/k: 4: 2); end. пример: -7 4 17-13 20 -8 12 11 15-17 -5 15-17 -4 14-12 3-20 6 -8-14 -8 18 17 6 -9 16 10 17 20-15 средняя температура дней с оттепелью = 13.00 2) const m=10; var a: array[1..m] of integer; i,s: integer; begin randomize; for i: =1 to m do begin a[i]: =random(21); write(a[i]: 4); end; writeln; s: =0; for i: =1 to m do if i mod 2 = 1 then s: =s+a[i]; writeln('s = ',s); for i: =1 to m do if i mod 2 = 0 then a[i]: =s; for i: =1 to m do write(a[i]: 4); writeln; end. пример: 14 9 0 8 6 2 2 16 1 16 s = 23 14 23 0 23 6 23 2 23 1 23