zigrin
?>

Составьте программу, которая вычисляет расстояние между двумя в километрах к, приняв, что 5 миль равны 8 км. город а находится в х милях от москвы. значения а и х вводятся с клавиатуры.

Информатика

Ответы

bestform
Var  a: string;   x, k: real; begin write('nazvanie goroda: '); readln(a); write('rasstoyanie ot g. ', a, ' do moskvy v milyah: ' ); readln(x); k : = x*8/5; writeln('gorod ', a, ' nahoditsya v ', k: 4: 2, ' km. ot moskvy.'); readln; end.
fshevxuzheva313

program massiv;

var a: array[-10..10] of integer;

begin  for i: =1 to 20 do read(a[i]);   for i: =1 to 20 do a[i]: =round(a[i]/10);

 

          for i: =1 to 20 do write(a[i]);

end. 

 

 

и вообще можно написать так

program massiv;

var a: array[-10..10] of integer;

begin  for i: =1 to 20 do

      begin 

          read(a[i]);

          a[i]: =round(a[i]/10);  

            write(a[i]);  

 

        end;

end.

 

 

 

 

 

 

ВладимировичСтанислав

program konkyrs; vara,b: integer; begin writeln ('введите рост и вес участника через пробел'); readln(a,b); if (a> =172) and (a< =184) then begin if (b> =70) and (b< =80) then writeln('подходит для конкурса') else writeln ('не подходит для конкурса'); end else writeln ('не подходит для конкурса'); readln; end.

  ошибка была в том что надо использовать вместо or (или) оператор and (и) ,а еще были пропущены точка с запятой после команды else    

   

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая вычисляет расстояние между двумя в километрах к, приняв, что 5 миль равны 8 км. город а находится в х милях от москвы. значения а и х вводятся с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nsn-2012
Назаров588
Качкова1820
Сергей_Евгеньевич1255
Vladimirovich-Aleksandrovna96
ftyh6
Malenyuk
galiyamart6671
Vos-sv
el-dent12
reinish23
chulki-kupit
Marina658
Anna572
▲