Var b: array [1..100] of integer; s,i: integer; begin for i: =1 to 100 do begin b[i]: =random(-100,100); if odd(b[i]) then s: =s+b[i]; end; write(s); end.
Мамедов
22.04.2023
Воператорах dat[1] : = 7; ; dat[10] : = 9; элементы массива. m : = 0; n : = 0; - начальные значения переменных m и n.в цикле for k : = 1 to 10 do каждый элемент массива сравнивается с текущим значением переменной m ( dat[k] > = m). если элемент больше, то значения переменных m и n меняются: в переменной m запоминается значение элемента массива, в переменной n - значение номера (индекс) этого элемента. таким образом, после выполнения цикла значения переменных будут: m=10; n=8. на экран будет выведено значение 8 (это номер последнего максимального элемента массива).ответ: 8
Виктория Нина
22.04.2023
// pascalabc.net 3.2, сборка 1427 от 24.04.2017 // внимание! если программа не работает, обновите версию! begin var a: =seqrandom(readinteger('n=',50).select(x-> x/10).toarray; a.println; var b: =a.where(x-> x< 0).orderbydescending(x-> x).toarray; var j: =0; for var i: =0 to a.length-1 do if a[i]< 0 then (a[i],j): =(b[j],j+1); a.println; end. пример n= 15 -3.6 -4.9 -4.2 1.8 -0.8 3.1 -3.3 -4.7 -2 4.1 3.1 2.3 4 -3.3 -1.6 -0.8 -1.6 -2 1.8 -3.3 3.1 -3.3 -3.6 -4.2 4.1 3.1 2.3 4 -4.7 -4.9
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу для решения следующей массив б задан случайным образом подсчитать сумму элементов массива состоящих из нечётных чисел