Напишите программу которая получает возраст человека и выводит его возраст со словами: год, года или нужно) но программа должна быть простая, так как я учусь в соц.гуме)
Var n: integer; begin readln(n); if (n mod 10 = 1) and ((n mod 100) div 10< > 1) then writeln(n,' год') else if ((n mod 10 = 2) or (n mod 10 = 3) or (n mod 10 = 4)) and ((n mod 100) div 10< > 1) then writeln(n,' года') else writeln(n,' лет'); end.
leeteukism
19.11.2020
Const n = 20; var i, k: integer; a: array[1..n] of longint; begin writeln('введите с клавиатуры ', n, ' целых чисел через пробел'); k : = 0; read(a[1]); for i : = 2 to n do begin read(a[i]); if ((a[i - 1] * a[i] mod 2) = 1) and ((a[i - 1] + a[i] mod 5) < > 0) then k : = k + 1 end; writeln(#13#10, 'найдено пар: ', k) end. тестовое решение: введите с клавиатуры 20 целых чисел через пробел 10 24 18 35 35 16 52 163 265 210 318 45 18 35 62 10 84 90 425 300 найдено пар; 2
julianikaleksandrova
19.11.2020
Технологическая революция к появлению термина "информационная эра" из-за того, что информационные системы стали частью нашей жизни и изменили ее коренным образом. информационная эра также изменила способ ведения боевых действий, обеспечив командиров беспрецедентным количеством и качеством информации. теперь командир может наблюдать за ходом ведения боевых действий, анализировать события и доводить информацию. следует различать войну информационной эры и информационную войну. война информационной эры использует информационную технологию как средство для успешного проведения боевых операций. напротив, информационная война рассматривает информацию как отдельный объект или потенциальное оружие и как выгодную цель. технологии информационной эры сделали возможной теоретическую возможность - прямое манипулирование информацией противника. что такое информация? информация появляется на основе событий окружающего мира. события должны быть восприняты каким-то образом и проинтерпретированы, чтобы стать информацией. поэтому информация результат двух вещей - воспринятых событий(данных) и команд, требуемых для интерпретации данных и связывания с ними значения. отметим, что это определение абсолютно не связано с технологией. тем не менее, что мы можем делать с информацией и как быстро мы можем это делать, зависит от технологии. поэтому введем понятие информационной функции - это любая деятельность, связанная с получением, передачей, хранением и трансформацией информации. каковы военные информационные функции? качество информации - показатель трудности ведения войны. чем более качественной информацией владеет командир, тем большие него преимущества по сравнению с его врагом. так в ввс сша анализ результатов разведки и прогноза погоды является основой для разработки полетного . точная навигация увеличивает эффективность выполнения . все вместе они являются военных информационных функций, которые увеличивают эффективность боевых операций. поэтому дадим определение военным информационным функциям - это любые информационные функции, обеспечивающие или улучшающие решение войсками своих боевых . что такое информационная война? на концептуальном уровне можно сказать, что государства стремятся приобрести информации, обеспечивающую выполнение их целей, воспользоваться ей и защитить ее. эти использование и защита могут осуществляться в , политической и военной сферах. знание об информации, которой владеет противник, является средством, позволяющим усилить нашу мощь и понизить мощь врага или противостоять ей, а также защитить наши ценности, включая нашу информацию. информационное оружие воздействует на информацию, которой владеет враг и его информационные функции. при этом наши информационные функции защищаются, что позволяет уменьшить его волю или возможности вести борьбу. поэтом дадим определение информационной войне - это любое действие по использованию, разрушению, искажению вражеской информации и ее функций; защите нашей информации против подобных действий; и использованию наших собственных военных информационных функций. это определение является основой для следующих утверждений. информационная война - это любая атака против информационной функции, независимо от применяемых средств. бомбардировка атс - операция информационной войны.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу которая получает возраст человека и выводит его возраст со словами: год, года или нужно) но программа должна быть простая, так как я учусь в соц.гуме)