yana2211
?>

Яна уроке ! составьте программу нахождения нод(наибольшего общего делителя) и нок(наименьшего общего кратного)двух чисел a и b.

Информатика

Ответы

moisalexx7
Для вычисления среднего учащихся, сдавших экзамен, нужно просмотреть все n=30 учащихся и найти сумму s и количество k для тех учащихся, которые набрали более 20 , а затем получить и вывести s/k с нужной точностью. const   n=30; var   x: array[1..n] of integer;   i,k,s: integer; begin   randomize;   writeln('результаты сдачи');   k: =0; s: =0;   for i: =1 to n do   begin       x[i]: =random(101);       write(x[i]: 4);       if x[i]> 20 then begin s: =s+x[i]; inc(k) end   end;   writeln;   writeln('средний сдавших равен ',s/k: 6: 3) end. тестовое решение: результаты сдачи   39  10  74  74  46  61  22  11    6  48  17  62  21  98  69  54  12    4  38  72  53  46  92  16  87  67  34  44  45  86 средний сдавших равен 57.913
rusplatok
Var   matrix : array[1..4, 1..4] of integer;   min, sum,  i, j  : integer; begin   min  : =  maxint;   sum : = 0;   for i: =1 to 4 do     for j: =1 to 4 do       read(matrix[i, j]);   for i: =1 to 4 do     for j: =1 to 4 do     begin       if matrix[i, j] < min then         min : = matrix[i, j];       sum : = sum + matrix[i, j];     end;   for i: =1 to 4 do     for j: =1 to 4 do       if matrix[i, j] < (sum / 16) then         matrix[i, j] : = min; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Яна уроке ! составьте программу нахождения нод(наибольшего общего делителя) и нок(наименьшего общего кратного)двух чисел a и b.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

oalexandrova75
manager9
axo4937
bakerkirill
eleniloy26
forosrozhkov
krikriska84
nadyatsoi
Lapushkin1988
pafanasiew
davidovalbert6
eduard495
Yelena1409
Vasilii1891
Александровна1685