Viktor1316
?>

Напишите программу, которая запрашивает у пользователя имена его друзей до тех пор, пока он не введет единицу. затем выведите на экран список со всеми именами, кроме первого.

Информатика

Ответы

Lapushkin1988

program raf105;

var

  friends: array of string;

  i: integer;

begin

  writeln('вводие имена своих друзей по очереди');

  writeln('чтобы закончить введите 1');

  repeat

    inc(i);

    setlength(friends,i);

    readln(friends[i-1]);

  until friends[i-1] = '1';

  writeln('список друзей начиная со второго: ');

  for i: =2 to i-1 do

    writeln(friends[i-1]);

end.

pascalabc
Mnatsovna

вообще-то маловато для такого .

допустим, что эта система счисления по основанию к. к - нам нужно найти.

тогда 56 запишется в этой системе следующим образом. при делении 56 на основании этой системы получаем какое -то целое число n, а в остатке 5.

 

56=n*k+5  (1)

 

тогда 124 запишется в этой системе следующим образом. здесь при делении 124 на основание этой системы получаем m, а в остатке 5.

124=m*k+5  (2)

отнимем из второго уравнения первое

 

68=mk-nk

 

68=k*(m-n)

 

теперь найдем целые делители числа 68. вообще-то лучше разложить 68 на простые множители.

 

это будет 2*2*17=68.

 

значит множители 68 будут основаниями искомой системы.

 

1) 2 - по этому основанию не может быть искомая система, так как на пятерку число не будет заканчиваться, потому что пятерки нет в двоичной системе.

 

2) 2*2=4 - по этому основанию не может быть искомая система, так как на пятерку число не может оканчиваться. пятерки нет в четверичной системе.

 

3) 17 - по этому основанию может быть система. так как пятерка есть в этой системе.

56=17*3+5. то есть в семнадцатиричной системе 56 будет записываться как 35.

124=17*7+5. в семнадцатиричной системе 124 записывается в виде 75.

 

4) 2*17=34. - по этому основанию может быть искомая система. здесь 56=34*1+22. только вот остатком пятерка уже не является. значит это решение нам не подходит.

 

5) 68 - основанием системы быть не может. так как 56 не выразится через это основание

 

ответ: основанием этой системы может лишь быть 17.

 

titov-es3095

program nalko; uses crt; const n = 10; var  a: array [1..n] of real;   i,k: integer; begin  writeln('*** alphaues is ***');   writeln('***                  ok                        ***');   randomize;   {ввод чисел}  for i: =1 to n do      begin          write('введите ',i,'-е число '); readln (a[i])      end;   writeln('корни и квадраты: ');   for i: =1 to n do      begin          write('a[',i,']=',a[i]: 7: 2,'  корень');           if a[i]< 0               then write(' не существует')              else write('=',sqrt(a[i]): 7: 2);           writeln('    квадрат=',a[i]*a[i]: 7: 2);       end; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая запрашивает у пользователя имена его друзей до тех пор, пока он не введет единицу. затем выведите на экран список со всеми именами, кроме первого.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

erere4443
turovskaya69
info-mosbalkon
d111180
Vladimirovna1370
Потапова 79275136869323
toniv
oslopovavera
mihalewanadia20176987
михаил
Fedorovich_Aleksandrovich685
likakedo4ka439
Яковчук1911
vsemvsego306
olegtarasov1965
▲