office3
?>

(python3: )мне нужна , мне нужно написать программу которая будет задавать вопросы та выдавать ответы, если ответ правильный то говорит что «правильно »а если нет то «ответ неверный »примерно 5 вопросов , и не должна быть сильно завалила всякими циклами​

Информатика

Ответы

elenalukanova

list_ask=[["тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ"],

["тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ"]]

for i in list_ask:

  answer=input(i[0])

  if answer==i[1]:

      print("твет верный")

  else:

    print("ответ не верный")

ps random:

import random as r

list_ask=[["тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ"],

["тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ""тут пишешь вопрос","а тут ответ"]]

for i in range(len(list_ask)):

  n=r.randint(0,len(list_ask))

  x=input(list_ask[n][0])

  if x==list_ask[n][1]:

    print("ответ верный")

  else:

    print("ответ не верный")

Кочугурова

выключить монитор - нажать на кнопку вкл/выкл на мониторе.

отсоединить монитор от компьютера - выключить питание, отсоединить кабель передачи цветовой картинки от пк.

отсоединить мышь и клавиатуру - вытащить usb провод мыши и клавиатуры от пк.

отсоединить все остальные имеющиеся внешние устройства кабеля - просто всё отсоединить

подключить к компьютеру монитор - подключить кабель питания монитора к 220v и подсоединить провод цветопередачи в пк

подключить шнур питания к компьютеру сети

включить компьютер и мониторазместите

mzubenko6

1. если алфавит содержит 64 символа, то его символы можно закодировать числами от 0 до 63. в двоичном коде для представления чисел такого диапазона потребуется 6 бит

ответ: потребуется код разрядности шесть бит.

2. пятиразрядный двоичный код позволяет закодировать  символа с от 0 до 31.

ответ: пятиразрядного кода будет недостаточно.

3. каждую лампочку можно представить битом. выключенной лампочке соответствует нулевое значение бита, включенной - единичное.

для передачи 15 различных сигналов потребуется четыре лампочки, поскольку , т.е. 4 лампочки способны передавать до 16 сигналов. трех лампочек будет недостаточно: они могут передать не больше сигналов.

ответ: потребуется четыре лампочки.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

(python3: )мне нужна , мне нужно написать программу которая будет задавать вопросы та выдавать ответы, если ответ правильный то говорит что «правильно »а если нет то «ответ неверный »примерно 5 вопросов , и не должна быть сильно завалила всякими циклами​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

AnnaChulyukanova3
Mukhina1811
Rakitin
bchukhraev79
oknacrow
annayarikova
Cannabikh
Оксана759
billl24
cherry-sweet871435
zimin0082
irina25095462
Бисеров-Чистякова
ivstigres65
uzunanna19922488