masum-2011687
?>

Построить блок-схему и написать программу для вычисления произведения четных чисел на паскале

Информатика

Ответы

khadisovam9
Const   csize = 10; var   m: array[1..csize] of integer; begin   randomize();   var max : = -(maxint);   write('исходный массив: ');   for var i : = 1 to csize do   begin       m[i] : = random(100) + 1;       if (i mod 2 = 0) and (m[i] > max) then max : = m[i];       write(m[i], ' ')   end;   write(newline, 'преобразованный массив: ');   for var i : = 1 to csize do   begin       if m[i] mod 3 = 0 then m[i] : = max;       write(m[i], ' ')   end end.
stperelyot7833
// pascalabc.net 3.1, сборка 1218 от 12.04.2016 begin   var a: =arrrandom(35,100,50000); a.println;   var k: =a.sum;   write('всего книг ',k);   if (k> =1000000) and (k< =9999999) then       writeln(' - шестизначное число')   else writeln(' - не шестизначное число') end. тестовые решения: 44847 40059 3938 43998 48227 2295 18961 36991 30123 41620 22198 13146 38442 8318 35835 49112 33119 4617 20383 19164 6367 30588 40391 31807 32046 49835 4990 817 31748 21075 16466 17557 44413 12879 803 всего книг 897175 - не шестизначное число 36802 44900 5012 30120 29288 21787 24640 41798 38286 34288 3756 5543 765 28259 26754 29598 15994 40577 26492 10557 41597 48459 13095 29019 30351 47939 35197 10527 43439 21960 40977 41831 43125 48076 10234 всего книг 1001042 - шестизначное число

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Построить блок-схему и написать программу для вычисления произведения четных чисел на паскале
Ваше имя (никнейм)*
Email*
Комментарий*