lpcck2212
?>

Написать программу в паскале и блок-сxему. : ввести 10 чисел, если число положительное, то от него отнять 0, 5, если число отрицательное, то ничего с ним не делать. вывести результат на экран.

Информатика

Ответы

mansur071199486
Var a,b,i: real; begin b: =0,5; for i = 1 to  10 do begin readln (a); if a< 0 then writeln (a) else a: =a-b; writeln (a); end; end.
beglovatatiyana

в паскале

1) program one;

uses crt; var a: array [1..10] of integer; x: real; i: integer; beginclrscr; x: =0; for i: =1 to 10 doreadln(a[i]); for i: =1 to 10 dobeginif (a[i]< 0) or (a[i] mod 2=0) thenx: =x+sqr(a[i]); end; writeln; write(x); end.

2)

program two; uses crt; var a: array [1..52] of integer; x,i: integer; beginclrscr; x: =34; for i: =1 to 52 dobegina[i]: =1+x; x: =x+1; if (a[i] mod 7 =1)or (a[i] mod 7 =2) or (a[i] mod 7 =5)then writeln(a[i]); end; end.

3)

program three; uses crt; var n,x: integer; a,y: real; beginclrscr; readln(a,n); for x: =1 to n doy: =x*a; writeln(y); end.

4)

program four; uses crt; var a: array [1..100] of integer; n,i,max,x: integer; begin clrscr; writeln('vvedite kol-vo elementov'); readln(n); writeln('vvedite elementy'); for i: =1 to n do read(a[i]); for i: =1 to n do begin max: =a[1]; if (a[i] < 0) and (a[i]> a[x]) then max: =a[i]; x: =i; end; writeln ('naib',max,'nomer',x); end.

5)

program abc; uses crt; var s,a,b: integer; beginclrscr; s: =0; a: =1; b: =3; while a< 98 dobeginwhile b< 100 dobegins: =s+b-a; a: =a+4; b: =b+4; end; end; writeln(s); end.

milanmilan8672
//pascalabc.net версия 3.2, сборка 1389 //если программа не запускается, то обновите версию begin       var n : = readlninteger('n =');       if (n < 100) or (n > 999) then begin               writeln('false');               halt;       end;             n : = n div 100 + (n div 10) mod 10 + n mod 10;       if n = 13 then               writeln('enter')       else               writeln('lock'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале и блок-сxему. : ввести 10 чисел, если число положительное, то от него отнять 0, 5, если число отрицательное, то ничего с ним не делать. вывести результат на экран.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Калмыкова-Петрунина
myataplatinumb348
kirill81
Gennadevna_Baidalina131
SlavaA99
alisapavlushina
khadisovam9
R7981827791127
ИльяАндреевич-Мария
Olegovna Volkov
NarekAlekseevich779
mereninka7008
Eduardovich_Sergei1062
thebest59
stasyan
▲