1. найти частное от деления двух целых чисел. 2. написать программу, которая проверяет, является ли введенное с клавиатуры целое число четным. и объясните , с решениями. а то я не понимаю ничего : с
1. var x,y: integer; z: real; begin write('введите два числа: '); readln(x,y); z: =x/y; writeln('их частное равно ',z) end.2.var x: integer; beginwrite('введите число: '); readln(x); if (x mod 2=0) then writeln('число четное') else writeln('число нечетное') end.
coffee2201
31.05.2023
Простой алгоритм, на самом деле. на псевдокоде: 1. сначала нам нужно ввести с клавиатуры три числа. 2. когда ввели, присваиваем переменной max значение a. предположим, что большее значение в a, и дальше по программе будем проверять это. max : = a. 3. проверяем, b > max? если да, то присваиваем переменной max значение b. 4. проверяем, max < c? если да, то присваиваем max значение c. 5. выводим max. реализация basic: input a input b input c max = a if b > max then max = b if max < c then max = c print max end c#: внутри главного метода. int max; int a = int.parse(console.; int b = int.parse(console.; int c = int.parse(console.; max = a; if (b > max) { max = b; } if (max < c){ max = с; } console.writeline(max); console.readline(); //чтобы программа не закрывалась сразу после выполнения