Sergei248
?>

Дан массив a(10) упорядочить элементы, массива по возрастанию. дан массив а(6) определить количество положительных элементов дан массив а(7)найдите количество четных четных положительных элементов дан массив а(8) найдите найдите сумму нечетных положительных элементов (составить программу на бейсике)

Информатика

Ответы

ccc712835
По  поводу первой не уверен в правильности во всех программах подразумевается, что массив уже создан и заполнен cls for i = 1 to 10   for j  = 1 to 10     if a(j)> a(j+1) then       c=a(j)       a(j)=a(j+1)       a(j+1)=c     end if   next j next i cls for i = 1 to 6  if a(i)> 0 then k=k+1 end if next i print k   cls  for i = 1 to 7  if a(i)> 0 and a(i) mod 2 =0 then k=k+1 end if next i print k   cls  for i = 1 to 7  if a(i)> 0 and a(i) mod 2 < > 0 then k=k+1 end if next i print k
ss2911
1)   var  n: integer; begin  readln(n);   if(n< 0)then write(0)  else write(n+4); end. 2)   var   a, b: integer;   begin   readln(a, b);   if(a = b) then write(1)   else write(0); end. 3) var   a, b, c, s: integer;   begin   s : = 0;   readln(a, b, c);   if(a > = 0) then s : = s + 1;   if(b > = 0) then s : = s + 1;   if(c > = 0) then s : = s + 1;   write(s); end. 4) var   a, b, c, s: integer;   begin   s : = 0;   readln(a, b, c);   if(a > 0) then s : = s + a;   if(b > 0) then s : = s + b;   if(c > 0) then s : = s + c;   write(s); end. 5)   var   a, b, c: integer;   begin   readln(a, b, c);   if (a < b) then swap(a, b);   if (a < c) then swap(a, c);   if (b < c) then swap(b, c);   write(a, ' ', b, ' ', c); end. 6)   var n, k, s, i: integer;   begin   s : = 0;   readln(n, k);   for i : = 1 to n.tostring.length do   if(strtoint(n.tostring[i]) > k) then s : = s + strtoint(n.tostring[i]);   write(s);   end. 7)   var n, s, i: integer;   begin   s : = 0;   readln(n);   for i : = 1 to n do     s : = s + i;   write(s);   end. 9)   var n, i: integer;   begin   readln(n);   for i : = n downto 1 do   write(i);   end. 12   var   n, i: integer;   s: real;   begin   s : = 0;   readln(n);   for i : = n downto 1 do   s: =s+(0.1*i);     write(s);   end. 13)   var n, i: integer;   begin   readln(n);   for i : = 1 to n do     write(sqr(i), ' '); end. 14)   var   n, i, c: integer;   begin   i : = 1;   c : = 0;   readln(n);   while (c < > n) do   begin     if(i mod 3 = 0) then begin write(i, ' '); c : = c + 1; end;     i : = i + 1;   end; end. 15)   var   n, i, a: integer;   c: real;   begin   i : = 1;   c : = 0;   readln(n);   for i : = 1 to n do     begin     read(a);     c : = c + a;   end;   write(c / n) end. 16)   var   n, i, a: integer;   begin   i : = 1;   while true do     begin     read(a);     if(a = 0) then break;     n : = n + 1;   end;   write(n) end.
axo-geo

Объяснение:

Некоторый сегмент сети Интернет состоит из 1000 сайтов. Поисковый сервер в автоматическом режиме составил таблицу ключевых слов для сайтов этого сегмента. Вот её фрагмент:

КЛЮЧЕВОЕ СЛОВО:

сомики

меченосцы

гуппи

КОЛИЧЕСТВО САЙТОВ, ДЛЯ КОТОРЫХ ДАННОЕ СЛОВО ЯВЛЯЕТСЯ КЛЮЧЕВЫМ:

250

200

500

По запросу сомики & гуппи было найдено 0 сайтов, по запросу сомики & меченосцы - 20 сайтов, а по запросу меченосцы & гуппи - 10 сайтов.

Сколько сайтов будет найдено по запросу сомики | месячном | Гуам?

Для скольких сайтов рассматриваемого сегмента ложно высказывание "Сомикм ключевое слово сайта ИЛИ меченцы - ключевое слово сайта"?

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив a(10) упорядочить элементы, массива по возрастанию. дан массив а(6) определить количество положительных элементов дан массив а(7)найдите количество четных четных положительных элементов дан массив а(8) найдите найдите сумму нечетных положительных элементов (составить программу на бейсике)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sokolova-Shcherbakov
vifslafes
opal19575
emilbadalov
tefdst
tata-novik
kotikdmytriy11
aidapiltoyan43
Исмагилова_Саният
egamedicalbuh
gbg231940
Шавкат кызы
alyonafialka
nadejdashin508
chizhenkovd9