chulki-kupit
?>

Python. напишите программу, которая запрашивает у пользователя количество строк для введенного стихотворения. дальше дает пользователю возможность пользователю ввести нужное число строк. затем нужно вывести количество строк, гласных и согласных в стихотворении и в каждой строке. пример входа: сколько будет строк? 4 я помню чудное мгновение передо мной явилась ты как мимолётное видение как гений чистой красоты пример результата: количество гласных: 36 количество согласных: 45

Информатика

Ответы

Елизавета Александр2011

на скриншоте ===============================

Staroverovanatasa494

Объяснение:

using System;

namespace ConsoleApp2

{

   class Program

   {

       static void Main(string[] args)

       {

           bool InArea = false;

           Console.Write("R=");

           double R = double.Parse(Console.ReadLine());

           Console.Write("x=");

           double x = double.Parse(Console.ReadLine());

           Console.Write("y=");

           double y = double.Parse(Console.ReadLine());

           // Проверяем попадает ли в полукруг

           if (x <= 0 && y >= 0 && x * x + y * y <= R * R) InArea = true;

           // Проверяем попадает ли в первую половинку треугольника

           // Уравнение прямой будет y=-2x  

           if (x > 0 && x <= R/2.0 && y >= -2*x && y<=0) InArea = true;

           // Проверяем попадает ли во вторую половинку треугольника

           // Уравнение прямой будет y=2x-2R  

           if (x > 0 && x <= R / 2.0 && y >= 2 * x - 2 * R && y <= 0) InArea = true;

           if(InArea) Console.WriteLine("Точка принадлежит области");

           else Console.WriteLine("Точка не принадлежит области");

           Console.ReadLine();

       }

   }

}

sargisyan77

Научно-практическая дисциплина, изучающая трудовые процессы с целью создания оптимальных условий труда росту его производительности.

Что бы настроить свое рабочее место нужно что бы у тебя было удобное кресло, что бы ты был доволен своим местом за компьютером ну и конечно надо иметь не плохой компьютер и девайсы !) Нельзя падать с кресла , нельзя кушать за столом , нельзя не протирать все из электронного у тебя на столе ! Честно за долгой работой над компьютером я ничего не делал и со мной все хорошо;Но нужно делать зарядку примерно каждый час! И делать разминку глаз !)

Удачи!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python. напишите программу, которая запрашивает у пользователя количество строк для введенного стихотворения. дальше дает пользователю возможность пользователю ввести нужное число строк. затем нужно вывести количество строк, гласных и согласных в стихотворении и в каждой строке. пример входа: сколько будет строк? 4 я помню чудное мгновение передо мной явилась ты как мимолётное видение как гений чистой красоты пример результата: количество гласных: 36 количество согласных: 45
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Лихачев Полина1978
SAMSCHOOL96
rimmaskis
mmreznichenko
Asira926
Аврамец1911
мария Кузив1393
Конычева-музей&quot;260
Azarenkoff
Azat859
det-skazka55
YaroslavSerganYS5
Kochinev4
Mariya987
bespalovaannaanna
▲