viktoritut
?>

Тема основы программирования на паскале музыкальный диск стоит x рублей. у вас имеется a рублей. хватит ли денег на покупку? в случае недостатка, определите, сколько денег надо добавить.

Информатика

Ответы

asemchenko
Если а> =х то хватит. а если не хватит, то нужно добавить х-а рублей
artem032100
// pascalabc.net 3.1, сборка 1219 от 16.04.2016 begin   var a,b,h,x: real;   write('введите a b h: '); read(a,b,h);   if a> b then swap(a,b); // поменять местами   if h< =0 then writeln('шаг h должен быть положительным')   else begin       x: =a;       while x< =b+h/2 do begin // +полшага на погрешность накопления           writeln('x=',x: 0: 4,',  y=',x> 0? 1/x-5: 2*x);           x+=h           end       end end. тестовое решение: введите a b h: -2.46 3.73 0.18 x=-2.4600,  y=-4.92 x=-2.2800,  y=-4.56 x=-2.1000,  y=-4.2 x=-1.9200,  y=-3.84 x=-1.7400,  y=-3.48 x=-1.5600,  y=-3.12 x=-1.3800,  y=-2.76 x=-1.2000,  y=-2.4 x=-1.0200,  y=-2.04 x=-0.8400,  y=-1.68 x=-0.6600,  y=-1.32 x=-0.4800,  y=-0.96 x=-0.3000,  y=-0.6 x=-0.1200,  y=-0.24 x=0.0600,  y=11.6666666666667 x=0.2400,  y=-0.83333333333333 x=0.4200,  y=-2.61904761904762 x=0.6000,  y=-3.33333333333333 x=0.7800,  y=-3.71794871794872 x=0.9600,  y=-3.95833333333333 x=1.1400,  y=-4.12280701754386 x=1.3200,  y=-4.24242424242424 x=1.5000,  y=-4.33333333333333 x=1.6800,  y=-4.4047619047619 x=1.8600,  y=-4.46236559139785 x=2.0400,  y=-4.50980392156863 x=2.2200,  y=-4.54954954954955 x=2.4000,  y=-4.58333333333333 x=2.5800,  y=-4.61240310077519 x=2.7600,  y=-4.63768115942029 x=2.9400,  y=-4.65986394557823 x=3.1200,  y=-4.67948717948718 x=3.3000,  y=-4.6969696969697 x=3.4800,  y=-4.71264367816092 x=3.6600,  y=-4.72677595628415
михаил

Нуу.. я думаю так:

Раньше, для того чтобы начать использовать программу, её достаточно было просто скопировать на свой компьютер. Сейчас большинство программ нужно устанавливать. Для этого есть важные причины:

некоторые программы могут работать только на достаточно мощных компьютерах...

программы содержат множество файлов, которые должны быть записаны на диск в определенные папки...

пользователь должен получить возможность выбрать нужные ему компоненты программы...

при установке некоторых программ необходимо вводить ключ...

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Тема основы программирования на паскале музыкальный диск стоит x рублей. у вас имеется a рублей. хватит ли денег на покупку? в случае недостатка, определите, сколько денег надо добавить.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sakh2010kprf7
mistersoshnev354
sohrokova809
Ильдар-Кугай
rezh2009766
ЭдуардовнаКлючников1361
kate1610
chapaevval
masha812
amayonova
olgapotapova
Вячеслав
ba5-m
tumanowivan2015509
novkatrina