annakorolkova79
?>

Решить на языке паскаля написать программу для определения того, находится ли вес человека в пределах нормы для определения нормального веса человекс из величины его роста вычитают 100. вес считается нормальным , если он отличается от этой разницы не более чем на 5 кг.

Информатика

Ответы

Ушакова1902
Program xxx; var rost,ves,resultat: real; begin writeln('добро в калькулятор веса.'); write('введите ваш вес: '); read(ves); write('введите ваш рост: '); read(rost); resultat: =rost-100; write('итог: ваш вес: ' ,ves); writeln('ваш рост: ' ,rost); write('ваш нормальный вес(+-5): ' ,resultat); end.
salahovta
1.  (число < 75) и не (число чётное)46:   (46< 75) и не (46 чётное)  ⇒ истина и ложь  ⇒ ложь 53:   (53< 75) и не (53 чётное)  ⇒ истина и истина ⇒ истина 80:   (80< 75) и не (80 чётное)  ⇒ ложь и ложь  ⇒ ложь 99:   (99< 75) и не (99 чётное)  ⇒ ложь и истина ⇒ ложь ответ:   2) 532.  не (первая буква согласная) или не (последняя буква гласная)пимен:   не ("п" согласная) или не ("н" гласная)  ⇒ ложь или истина  ⇒ истина кристина:   не ("к" согласная) или не ("а" гласная)  ⇒ ложь или ложь ⇒ ложь ирина:   не ("и" согласная) или не ("а" гласная)  ⇒ истина или ложь ⇒ истина александр:   не ("а" согласная) или не ("р" гласная)  ⇒ истина или истина  ⇒ истина ответ:   2) кристина3.  не (число > 30) или (число нечётное)28:   не (28 > 30) или (28 нечётное)  ⇒ истина или ложь  ⇒ истина 34:   не (34 > 30) или (34 нечётное)  ⇒ ложь или ложь  ⇒ ложь 17:   не (17 > 30) или (17 нечётное)  ⇒ истина или истина  ⇒ истина 45:   не (45 > 30) или (45 нечётное)    ⇒ ложь или истина  ⇒ истина ответ: 2) 34
zoocenterivanoff51
1. begin   var a: =arrrandom(10,1,50); a.println;   var c: =readinteger('c = ');   var s: =a.where(x-> x> c);   if s.count> 0 then   writeln('среднее арифметическое элементов > ',c,' = ',s.average)   else writeln('в массиве нет искомых элементов'); end. пример: 8 2 22 16 24 34 29 16 1 26 c =  50 в массиве нет искомых элементов 2. const n=10; var a: array[1..n] of integer; c,i,s,k: integer; begin randomize; for i: =1 to n do begin   a[i]: =random(51);   write(a[i],' ');   end; writeln; write('c = '); readln(c); s: =0; k: =0; for i: =1 to n do   if a[i]> c then begin s: =s+a[i]; k: =k+1; end; if k> 0 then writeln('среднее арифметическое элементов > ',c,' = ',s/k: 5: 2) else writeln('в массиве нет искомых элементов'); end. пример: 39 38 43 25 45 16 16 12 35 16c = 40среднее арифметическое элементов > 40 = 44.00

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить на языке паскаля написать программу для определения того, находится ли вес человека в пределах нормы для определения нормального веса человекс из величины его роста вычитают 100. вес считается нормальным , если он отличается от этой разницы не более чем на 5 кг.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bellaalya13862
gardenstreet5
mrvasilev2012
girra
Sergeevich-irina
Baidina
stark11
Tadevosyan
sveta1864
ellyb106786
Vasilevich Fokin
eshabunina
abahtina582
Ushakova Sakhno
vera-sherepa231