vikanikita
?>

Написать программу! 1. запишите следующие условия: числа a и b имеют разную четность. одно из чисел a и b положительно. одно из чисел a и b является квадратом другого. точка a(x, y) принадлежит первому и второму квадранту. число a не больше среднего арифметического чисел b, c, d.

Информатика

Ответы

Verdievruslan
Паскаль авс: числа a и b имеют разную четность.if (a mod 2) < > (b mod 2) thenодно из чисел a и b положительно. if (a > 0) or (b > 0) then  одно из чисел a и b является квадратом другого.if (a=b*b) or (b=a*a) thenточка a(x,y) принадлежит первому или второму квадранту. if (y > 0) thenчисло a не больше среднего арифметического чисел b, c, d. if (a < = (b+c+d)/3) then
dashkevich-76611
Program project1; var m: array of integer; n, i, old, simple: integer; function nod (var a,b: integer): integer; var c: integer; begin   repeat       if a > b then           a : = a mod b       else           b : = b mod a;   until (a = 0) or (b = 0);   nod : = a + b; end; function issimple(const n: integer): boolean; var i: integer; begin   issimple: =true;   for i: =0 to length(m)-1 do begin       if (n mod m[i])=0 then begin           issimple: =false;           break;       end;   end; end; begin   repeat       write('n: '); readln(n);       setlength(m, length(m)+1);       m[length(m)-1]: =n;   until n< =0;   setlength(m, length(m)-1);     old: =nod(m[0], m[1]);   for i: =2 to length(m)-1 do       old: =nod(old, m[i]);   writeln('nod: ', old);   simple: =0;   for i: =0 to length(m)-1 do       if issimple(m[i]) then           inc(simple);   writeln('simple: ', simple);   readln; end. нахождение нод всех чисел это нод(нод(а, б), в) и т.д. остальное думаю понятно.
shuttse
Program project1; var m: array of integer; n, i, summ: integer; begin   repeat       write('n: '); readln(n);       setlength(m, length(m)+1);       m[length(m)-1]: =n;   until n=0;   setlength(m, length(m)-1);   n: =0; summ: =0;   for i: =0 to length(m)-1 do begin       if m[i]> 12 then begin           inc(n);           inc(summ, m[i]);       end;   end;   writeln('result: =', summ/n);   readln; end. 2) program project1; var n, t, res: integer; begin   write('n: ='); readln(n);   res: =1;   while n> 0 do begin       t: =(n mod 10);       if t< 4 then res: =res*t;       n: =n div 10;   end;   writeln('result: =', res);   readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу! 1. запишите следующие условия: числа a и b имеют разную четность. одно из чисел a и b положительно. одно из чисел a и b является квадратом другого. точка a(x, y) принадлежит первому и второму квадранту. число a не больше среднего арифметического чисел b, c, d.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Федоровна-Васильева
katyn76
plio67380
Komarovsergeysk
fishka-sokol14
dilbaryan76
siger06297
georgegradoff122
mihalevskayat
Манько_Панферов
ekasatkina
Bezzubova_Stepanov1355
zibuxin6
nasrelza1012
a8227775