АлександровнаВладимирович1424
?>

Напишите программу на языке ! нужно вычислить сумму модулей трех чисел действительных чисел . сама ничего не понимаю ни в информатике ни в .

Информатика

Ответы

kv135549
Кпримеру.  ŀx+1lмодулем действительного число называется расстояние от начала отсчёта до точки, соответствующей данному числу. например, i4i=4, i-5i=5, i0i=0. есть ещё такое определение. оно используется при решении уравнений и неравенств. iхi=х, если х> =0 (модуль неотрицательного числа равен самому себе) iхi=-х, если х< 0 (модуль отрицательного числа равен числу, ему противоположному) . в вашем примере: iх+1i=х+1, если х+1> =0, то есть х> =-1 iх+1i=-х-1, если х+1< 0, то есть х< -1
vitaldicky349
// pascalabc.net 3.0, сборка 1157 от 02.02.2016 begin   var n: =readinteger('n=');   if n< 0 then writeln(n,'! не определено: n< 0')   else       if n=0 then writeln('0! =1')       else begin           var p: biginteger: =1;           for var i: =2 to n do p*=i;           writeln(n,'! =',p)           end end. тестовое решение: n= 138 138! =691778647261948849222819828311491035886734385827028118707676848307166514238979223884785249055995983385450621636277440066920043595627074569065446040152660143904127838730788278294186615891819670506731208704000000000000000000000000000000000
Александрович
Program project2;   {$apptype console} uses  sysutils; var a: array [0..9] of integer;     i,max,indx,tmp: integer; begin    randomize;     for i: =0 to 9 do    a[i]: =random(10);       for i: =0 to 9 do    write(a[i]: 3);     writeln;     max: =a[0];     indx: =0;     for i: =0 to 9 do    if a[i]> max then    begin      max: =a[i];       indx: =i;     end;     tmp: =a[0];   a[0]: =max;   a[indx]: =tmp;   for i: =0 to 9 do     write(a[i]: 3);   readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на языке ! нужно вычислить сумму модулей трех чисел действительных чисел . сама ничего не понимаю ни в информатике ни в .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ba5-m
dm1trviktor585
panasenko68
chetverikovalex3738
echervyakov
ValerevnaRustam1072
krasilnikov74
ismailovi670771
Сергей_Комарова899
astenSA
dmitrievanata83538
natalya2321
Elvira-Natalya
FinKozhevnikov28
dshi67orbru