sarycheva659
?>

Напишите программу, которая сортирует массив и находит количество различных чисел в нем. используйте алгоритм быстрой сортировки. пример: массив: 5 3 4 2 1 6 3 2 4 после сортировки: 1 2 2 3 3 4 4 5 6 различных чисел: 5

Информатика

Ответы

gallows-warlike-0z
Var i, j, h, a, z, n, k: integer; array1: array [1..100] of integer; array2: array [1..100] of integer; procedure swap(var x, y: integer); var t: integer; begin t : = x; x : = y; y : = t end; begin randomize; write('введите значение n: '); readln(n); for i : = 1 to n do begin array1[i] : = random(10) + 1; end; for i : = 1 to n do begin writeln('массив: '); for i : = 1 to n do write(array1[i], ' '); writeln; end; for h : = 1 to n - 1 do for z : = 1 to n - h do if array1[z] > array1[z + 1] then swap(array1[z], array1[z + 1]); for i : = 1 to n do begin writeln('после сортировки: '); for i : = 1 to n do write(array1[i], ' '); writeln; end; for i: =1 to n do begin k : = 0; for j : = 1 to n do if array1[i] < > array1[j] then k: =k+1; if k = n - 1 then array2[i] : = array1[i]; end; for i : = 1 to n do if array2[i] > 0 then a : = a + 1; writeln('различных чисел: ', a); end.
zrs-546

===== PascalABC.NET =====

begin

 var f := CreateFile&<real>('MyFile.bin');

 // создаем и заполняем файл

 loop 10 do // файл на 10 чисел

   Write(f, Random(100.0));

 // ищем минимум и максимум

 var (min, max) := (200.0, -100.0);

 f.Seek(0);

 var t: real;

 while not f.Eof do

 begin

   Read(f, t);

   if t > max then

     max := t

   else if t < min then

     min := t;

 end;

 // дозапись в файл

 Write(f, max);

 Write(f, min);

 // если надо - контрольный вывод

 f.Seek(0);

 while not f.Eof do

 begin

   Read(f,t);

   Print(t)

 end;

 // закрыть файл

 f.Close;

end.

Salko17

                                  1  

Информационная безопасность — состояние сохранности информационных ресурсов государства и защищённости законных прав личности и общества в информационной сфере.

                                   2

Защита информации - это перечень мероприятий, направленных на достижение полной безопасности и защищенности сведений с целью предотвращения утечки информации.

                               3

https://ru-static.z-dn.net/files/db0/f62b89f6cbda70f9010f99e45cc4e273.jpg

                                4

1. Защиту объектов информационной безопасности - это сервера, базы данных и электронная почта т.п.

2. Защита процессов, процедур и программ обработки информации - это защита сети предприятия, защита каналов передачи данных, защита систем управления базами данных и т.п.

3. Подавление побочных электромагнитных излучений - с целью не допускания обрыва связи и искажения передаваемых данных;

4. Ну и непосредственно организация управления системой защиты - установка, контроль, профилактика и т.п.

                                        5.

https://ru-static.z-dn.net/files/dde/b2cd8f6781336ecd80571e74a29c802c.jpg

                                      6

Инсайдер (англ. insider) — член какой-либо группы людей, имеющей доступ к информации, недоступной широкой публике. Термин используется в контексте, связанном с секретной...

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая сортирует массив и находит количество различных чисел в нем. используйте алгоритм быстрой сортировки. пример: массив: 5 3 4 2 1 6 3 2 4 после сортировки: 1 2 2 3 3 4 4 5 6 различных чисел: 5
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aleksandramir90
TatiyanaBe20135263
shalashcoffee
len22
kolgatin69
Сергеевич1386
komarov-dmitriy
Светлана
Seropyan-Elena1944
len22
ivshzam
tarja4140
Malenyuk
kagurkina
Курнев-Анастасия359
▲