reinish23
?>

Написать программу, которая по паролю будет определять уровень доступа сотрудника к секретной информации в базе данных. доступ к базе имеют только шесть человек, разбитых на три группы по степени доступа. они имеют следующие пароли: 9583, 1747 — доступны модули баз а, в, с; 3331, 7922 — доступны модули баз в, с; 9455, 8997 — доступен модуль базы с. надо до завтра

Информатика

Ответы

sve707ta
Var key: integer; begin readln(key); case key of 9583,1747: writeln('a, b, c'); 3331,7922: writeln('b, c'); 9455,8997: writeln('c'); end; end.
annino
Program amstrong; var   a,b: integer;   i,j,k,   ci,   si,mi,   errkod: integer;   sti: string;   flag: boolean; begin   readln(a,b);   flag: =false;   for i: =a to b do   begin       str(i, sti);       si: =0;       for j: =1 to length(sti) do       begin           val(sti[j],mi,errkod);           ci: =1;           for k: =1 to length(sti) do               ci: =ci*mi;           si: =si+ci;       end;       if si=i then       begin           write(si,' ');           flag: =true       end;   end;   if not flag then write(-1);   readln;   end.
vkaloshin
Program amstrong; var   a,b: integer;   i,j,k,   ci,   si,mi,   errkod: integer;   sti: string;   flag: boolean; begin   readln(a,b);   flag: =false;   for i: =a to b do   begin       str(i, sti);       si: =0;       for j: =1 to length(sti) do       begin           val(sti[j],mi,errkod);           ci: =1;           for k: =1 to length(sti) do               ci: =ci*mi;           si: =si+ci;       end;       if si=i then       begin           write(si,' ');           flag: =true       end;   end;   if not flag then write(-1);   readln;   end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая по паролю будет определять уровень доступа сотрудника к секретной информации в базе данных. доступ к базе имеют только шесть человек, разбитых на три группы по степени доступа. они имеют следующие пароли: 9583, 1747 — доступны модули баз а, в, с; 3331, 7922 — доступны модули баз в, с; 9455, 8997 — доступен модуль базы с. надо до завтра
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

akrivoz
murza2007
jenn055
natalya2321
yelenaSmiryagin
maestro6838
Смирнов_Андрей691
Natysya7777
Chervonnaya-Aleksei
arutchevben64
snip99
Виталий
morozmd
vypolga1347
mariy-y34