Viktoriya405
?>

Написать программу расчета функции y=cos(x)*π/x с шагом 0, 1 в диапазоне от b до 5, с проверкой диапазона на программу паскаль

Информатика

Ответы

espectr-m
Var  x,y,b: real; begin b: =6; while b> =5 do   begin   writeln('введите параметр b (b< 5): ');   readln(b);   end; x: =b; writeln('x': 2,'y': 6); repeat  y: =cos(x)*pi/x;     writeln(x: 3: 1,' ',y);     x: =x+0.1;   until x> 5; end.
bykotatyana
#include < stdio.h> #include < stdlib.h> int main()  {     int n=10, h;     int a[n];       srand (time(null));     for (int i=0; i< n; i++)         {         a[i] = rand() % 21 - 10;         printf ("%4d ", a[i]);         }     printf("\n");     for (int i=0; i< n/4; i++){     h = a[i]; a[i] = a[n/2-i-1]; a[n/2-i-1] = h;     }     for (int i=n/2; i< 3*n/4; i++){     h = a[i]; a[i] = a[3*n/2-i-1]; a[3*n/2-i-1] = h;     }     for (int i=0; i< n; i++) printf ("%4d ", a[i]);     printf("\n");     return 0; } пример: -4 -10 -2 -8 3 -2 1 -5 -6 -53 -8 -2 -10 -4 -5 -6 -5 1 -2
vahmistrova
#include < stdio.h> #include < stdlib.h> int main() {        printf("input of 10 elements on an interval [-10; 10]: \n");     int a = -10, b = 10, i, arr[10];           for(i = 0; i < 10; i++)        {                    printf("\na[%d] = ", i);               scanf("%d", & arr[i]);         }     for(i = 0; i < 5; i++)        {          arr[i] = -arr[i];     }     for(i = 5; i < 10; i++)      {                arr[i] = -arr[i];         }         printf("\nmassiv with inversion: \n");     for(i = 0; i < 10; i++)        {           if(arr[i] > = a & & arr[i] < = b)           {                          printf("\na[%d] = %d", i, arr[i]);               }          else printf("\nerror input");         }         return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу расчета функции y=cos(x)*π/x с шагом 0, 1 в диапазоне от b до 5, с проверкой диапазона на программу паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Тоноян
elenaperemena8
Васильевич Валерьевна
Lugovoi
mmoskow3
opal19575
yurick2071488
ooo-helpvet44
karpovaveronika196
НосовЖелиховская
alislisa191
sveta740450
pimenov5
Shamsulo
samiramoskva