Дмитрий_Евлампиев518
?>

Написать программу, которая подсчитывает количество элементов и их сумму, которые кратны k, но не кратны m. (язык программирования - паскаль)

Информатика

Ответы

yurievaalxndra55
Цикл начинается с того, что сразу же присваивает х значение 0.4, и после этого для у производятся вычисление исходя из х = 0.4. чтобы х был изначально равен 0, нужно поменять местами строки в цикле, выглядит это так: var   x, y, h: real; begin   h : = 0.4;   repeat       y : = power(x, 1 / 3) - 1;       x : = x + h;       writeln(y);   until x > = 4; end.здесь значение переменной у сначала будет равно результату вычисления, при котором х еще равен 0.строку x: =0; можно убрать, так как при  объявлении переменной (в разделе var)  ей  присваивается 0 по умолчанию.а также, есть лишняя переменная с.
grachevakaterina
Var used: set of char;       s1, s2: string;       i: integer;       done: boolean;       c: char; function isletter(c: char): boolean; begin   isletter : = ((c > = 'a') and (c < = 'z')) or ((c > = 'a') and (c < = 'z')); end; function uppercase(c: char): char; begin   if (c > = 'a') and (c < = 'z') then       uppercase : = chr(ord(c) - ord('a') + ord('a'))   else       uppercase : = c; end; begin used : = []; readln(s1); readln(s2); for i : = 1 to length(s1) do   if (isletter(s1[i])) then       include(used, uppercase(s1[i])); for i : = 1 to length(s2) do   if (isletter(s2[i])) then       include(used, uppercase(s2[i])); done : = false; for c : = 'a' to 'z' do   if not (c in used) then   begin       done : = true;       write(c);   end; if not done then   write(0); writeln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая подсчитывает количество элементов и их сумму, которые кратны k, но не кратны m. (язык программирования - паскаль)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Виктория1690
natalia-shelkovich
lsuvorova1987
olg14855767
suhanowaswetlana
svetrusval
elyashatdinova
hobpack
dilanarthur27
ibarskova1542
schumacher8
Dmitrychekov9
denis302007
symkifm
arutchevben64
▲