mg4954531175
?>

Через 10 минут сдавать на питоне ! имеется n кг металлического сплава. из него изготавливают заготовки массой k кг каждая. после этого из каждой заготовки вытачиваются детали массой m кг каждая (из каждой заготовки вытачивают максимально возможное количество деталей если от заготовок после этого что-то остается, то этот материал возвращают к началу производственного цикла и сплавляют с тем, что осталось при изготовлении заготовок. если того сплава, который получился, достаточно для изготовления хотя бы одной заготовки, то из него снова изготавливают заготовки, из них – детали и т.д. напишите программу, которая вычислит, какое количество деталей может быть получено по этой технологии из имеющихся исходно n кг сплава. входные данные вводятся n, k, m. все числа натуральные и не превосходят 200. выходные данные выведите одно число — количество деталей, которое может получиться по такой технологии. примеры входные данные 10 5 2 выходные данные 4 входные данные 13 5 3 выходные данные 3 входные данные 14 5 3 выходные данные 4 входные данные 13 9 4 выходные данные 2

Информатика

Ответы

mrilyushchenko6

13467854785 правельна а может нет

evatautes

ответ:

объяснение:

2.

итерационные циклы

while, repeat - until

условие выполнения цикла может быть любым выражением, возвращающим тип boolean

шаг изменения любой

цикл с параметром

for

начальное и конечное значения - целые числа

шаг изменения параметра равно 1

количество итераций = [конечная граница] - [начальная граница] + 1

3.

цикл с предусловием  

while

минимальное количество итераций = 0 (случай, когда условие while не выполняется при первом проходе)

максимальное количество не ограничено

цикл с постусловием

repeat - until

минимальное количество итераций = 1 (условие выхода проверяется в конце цикла, хотя бы один раз цикл выполнится)

максимальное количество не ограничено

Manyaya

ответ: тигры занесены в красную книгу, к ним нужно относиться бережно : -)

program chetnechet;

var

  a, b, chet, nechet, otvet, i: integer;

begin

  write ('введите а, в: ');

  readln (a, b);

  chet : = 0;

  nechet : = 0;

  for i : = a to b do begin

    if i mod 2 = 0 then

      inc (chet)

    else

      inc (nechet);

  end;

  otvet : = chet - nechet;

  writeln ('четных: ', chet);

  writeln ('нечетных: ', nechet);

  writeln ('ответ: ', otvet);

  readln;

end.

объяснение:

for i : = a to b do begin

цикл перебирает числа от а до в включительно.

если верхняя граница должна быть в + 1 то есть на 1 больше, то исправьте

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Через 10 минут сдавать на питоне ! имеется n кг металлического сплава. из него изготавливают заготовки массой k кг каждая. после этого из каждой заготовки вытачиваются детали массой m кг каждая (из каждой заготовки вытачивают максимально возможное количество деталей если от заготовок после этого что-то остается, то этот материал возвращают к началу производственного цикла и сплавляют с тем, что осталось при изготовлении заготовок. если того сплава, который получился, достаточно для изготовления хотя бы одной заготовки, то из него снова изготавливают заготовки, из них – детали и т.д. напишите программу, которая вычислит, какое количество деталей может быть получено по этой технологии из имеющихся исходно n кг сплава. входные данные вводятся n, k, m. все числа натуральные и не превосходят 200. выходные данные выведите одно число — количество деталей, которое может получиться по такой технологии. примеры входные данные 10 5 2 выходные данные 4 входные данные 13 5 3 выходные данные 3 входные данные 14 5 3 выходные данные 4 входные данные 13 9 4 выходные данные 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sleek73
ka-shop
Varagyan1728
aobuhta4
Кириллов57
zoyalexa495
volodin-alexander
elenarumack
ShafetdinovAndrei
Александра-Андрей909
Bulanova
Пронкина_TEST1682
Максим
innaterenina
gav973
▲