petrovichvit2933
?>

Нужно написать программу в паскале описать функцию quarter(x, y) целого типа, определяющую номер координатной четверти, в которой находится точка с ненулевыми вещественными координатами (x, y с этой функции найти номера координатных четвертей для трех точек с данными ненулевыми координатами.

Информатика

Ответы

razumeiko0790
Var     i: integer;     x,y: real; function quarter(x,y: real): integer; begin if (x> 0) and (y> 0) then result: =1; if (x< 0) and (y> 0) then result: =2; if (x< 0) and (y< 0) then result: =3; if (x> 0) and (y< 0) then result: =4; end; begin writeln('введите координаты точки'); readln(x,y); i: =quarter(x,y); writeln('номер координатной четверти; ',i) end.
Bolshakova Shigorina

) ТБВ, 2) ЛЕЕТРФ, 3) 240АЯ, 4) 3

Объяснение:

1) БРА (длина нечетная) → РА (меняем буквы на следующие) → СБ (длина четная) → САБ (меняем буквы на следующие) → ТБВ

2) ГРОТ (длина четная) → ГГРОТ (меняем...) → ДДСПУ (длина нечетная) → КДДСПУ (меняем...) → ЛЕЕТРФ

3) 28МАЯ (длина нечетная) → 28АЯ (меняем цифры на следующие) → 39АЯ (длина четная) → 139АЯ (меняем...) → 240АЯ

4)  По первому правилу не подходит EHA, остались HCA AEA DAH ECC EEH ADE CEA AED

По второму правилу не подходят ECC, ADE и AED; остались HCA AEA DAH EEH CEA

По третьему правилу не подходят AEA и CEA ; остались HCA DAH EEH

Климова1317

Объяснение:

Для редактирования документов существуют несколько Выделение части текста протаскиванием указателя мыши или нажатием клавиш-стрелок при удерживаемой клавише. 2. Вырезка, копирование и вставка части текста либо сочетанием горячих клавиш +, +, + соответственно, либо при меню Edit (Правка) , контекстного меню или панели Standard (Стандартная) . Кроме того, существуют развитые средства форматирования текста, такие как управление типом и размером шрифта, выравниванием и т. п. Большинство этих возможностей реализуется при панели инструментов Formatting (Форматирование) .

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу в паскале описать функцию quarter(x, y) целого типа, определяющую номер координатной четверти, в которой находится точка с ненулевыми вещественными координатами (x, y с этой функции найти номера координатных четвертей для трех точек с данными ненулевыми координатами.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Peshkov
Роман_Гречина
Andreeva
alexandrxzx09
vuyakovleva
Вадим
irina-mic
bmargarita
Григорьевич915
PetrovDrozdov1785
Андрей Анна22
vallium8354
Jannadon77
olelukoya4
Александровна1973