dmitzu8594
?>

1. написать программу, которая выводит на экран в столбик таблицу умножения числа n (вводится пользователем во время выполнения программы) на числа от 1 до 20. паскаль, цикл с постусловием

Информатика

Ответы

Ragim777hazarovich

Операционные системы классифицируются по:

количеству одновременно работающих пользователей: однопользовательские, многопользовательские;числу процессов, одновременно выполняемых под управлением системы: однозадачные, многозадачные;количеству поддерживаемых процессоров: однопроцессорные, многопроцессорные;разрядности кода ОС: 8-разрядные, 16-разрядные, 32-разрядные, 64-разрядные;типу интерфейса: командные (текстовые) и объектно-ориентированные (графические);типу доступа пользователя к ЭВМ: с пакетной обработкой, с разделением времени, реального времени;типу использования ресурсов: сетевые, локальные.

В соответствии с первым признаком классификации многопользовательские операционные системы, в отличие от однопользовательских, поддерживают одновременную работу на ЭВМ нескольких пользователей за различными терминалами.

Второй признак предполагает деление ОС на многозадачные и однозадачные. Понятие многозадачности означает поддержку параллельного выполнения нескольких программ, существующих в рамках одной вычислительной системы, в один момент времени. Однозадачные ОС поддерживают режим выполнения только одной программы в отдельный момент времени.

В соответствии с третьим признаком многопроцессорные ОС, в отличие от однопроцессорных, поддерживают режим распределения ресурсов нескольких процессоров для решения той или иной задачи.

rn3ay8
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

№1

function IsGood(n:integer):boolean;
begin
  n:=Abs(n);
  var s:=0;
  while n>0 do begin
    s+=n mod 10;
    n:=n div 10
    end;
  Result:=s=10
end;

begin
  var k:=ReadSeqIntegerWhile(t->t<>0).Where(t->IsGood(t)).Count;
  Writeln(k,' чисел с суммой цифр, равной 10')
end.

Пример
-5234 20043 52340 10531 -64 31502 0
2 чисел с суммой цифр, равной 10

№2

begin
  var n:=ReadInteger('Введите число:');
  if n<=1 then Writeln(n,'!=',1)
  else Writeln(n,'!=',1.To(n).Aggregate(BigInteger(1),(i,j)->i*j))
end.

Примеры
Введите число: 5
5!=120

Введите число: 20
20!=2432902008176640000

Введите число: 100
100!=93326215443944152681699238856266700490715968264381621468592963895217599993229915608941463976156518286253697920827223758251185210916864000000000000000000000000

№3

begin
  if ReadInteger('Введите число:').ToString.GroupBy(t->t).
      Select(t->(t.Key,t.Count)).Any(t->t[1]>1)
  then Writeln('Число содержит по крайней мере две одинаковые цифры')
  else Writeln('Введенное число не содержит одинаковых цифр')
end.

Примеры
Введите число: 12345670
Введенное число не содержит одинаковых цифр

Введите число: 1320624
Число содержит по крайней мере две одинаковые цифры

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. написать программу, которая выводит на экран в столбик таблицу умножения числа n (вводится пользователем во время выполнения программы) на числа от 1 до 20. паскаль, цикл с постусловием
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

marvindkc
nickcook424
Викторович
urazmetova
Evagg3856
vodolaz8384
borisrogovpr3407
macmakka
fastprofit
zadvornovakrmst
Korobeinikov-Yulich23
АлексейГагиковна1774
mansur071199486
vrn3314
garikman-flesh486