dimaaristov
?>

Люди ! 1)составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями. 2)составьте программу заполнения массива из десяти чисел следующими значениями а) 2 4 6 8 10 (+ 2) б)3 6 9 12 15 (+3)

Информатика

Ответы

ekaterinapetrenko877529

2) задаеш размер масива константой и присваеваеш значение 10

первому елементу масива присваеваеш значение а) 2; б)3 и потом в цикле от 2 до 10 

каждому елементу присваеваеш значение предыдущего а) +2 ; б) +3

mas[i]=mas[i-1]+2;

mas[i]=mas[i-1]+3;

1)с етой совсем просто, я цикле от 1 до 10 с функции random каждому елементу масива присваивается случайное значение.

randomize;

mas[i]=random(20+1);

Lavka2017
Можно, долго не размышляя, решить методом "тупого  перебора". program specialhappytickets; var   i, j, k, l, m, n, s: integer; begin   s : = 0;   for i : = 0 to 9 do       for j : = 0 to 9 do           for k : = 0 to 9 do               for l : = 0 to 9 do                   for m : = 0 to 9 do                       for n : = 0 to 9 do                           if (i + j + k) = (l + m + n) then                               if i + j + k = 13 then s : = s + 1;   writeln(s) end. результат выполнения программы: 5625
avanesss
Прежде всего, код надо отформатировать и исправить имеющиеся в нем ошибки. а затем приступать к его рассмотрению. var   a, b: integer; procedure proc(var a: integer; b: integer); begin   b : = 4; a : = 6; b : = a + b end; begin   a : = 2; b : = 3;   proc(a, b);   writeln(a, ' ', b) end. описаны две целочисленные переменные a и b. им присваиваются значения 2 и 3 соответственно. затем следует вызов процедуры proc, в которую эти переменные в качестве параметров. на входе в proc получаем a=2, b=3. далее b получает значение 4, а получает значение 6 и затем b получает значение суммы a+b, т.е. 4+6=10. на этом работа процедуры завершается. поскольку параметр процедуры a имеет описатель var, то в основную программу вернется значение, которое a имело внутри процедуры (т.е. 6). значение b=10 действует только внутри процедуры и в основную программу не вернется. следовательно, в основной программа значение а поменяется на 6, а значение b сохранится прежним (3). в результате на выходе будет строка: 6 3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Люди ! 1)составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями. 2)составьте программу заполнения массива из десяти чисел следующими значениями а) 2 4 6 8 10 (+ 2) б)3 6 9 12 15 (+3)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mir5552
Викторович
elenaftdv7
amayonova
Tatyanaaarzieva72
Анатольевна
Li-111
polotovsky
korotinadasha07
sky-elena712558
nord0764
kzhgutova
ivanovmk1977
Belov Yekaterina639
chuev4444