Написать программу на языке паскаль, которая вычисляет значение заданной в таблице функции y . вывести в окне программы результаты для трех вариантов переменной x.
Program b1; var y,x1,x2,x3: real; begin writeln('write x1,x2,x3 : '); readln(x1,x2,x3); if x1> 4 then writeln(sqrt(abs(sin(sqr(x1)-1)/cos(sqr(x1)-: 10: 20); if x1> =0 then if x1< =4 then writeln(-2*x1: 10: 20); if x1< 0 then writeln(exp(cos(x1)): 10: 20); if x2> 4 then writeln(sqrt(abs(sin(sqr(x2)-1)/cos(sqr(x2)-: 10: 20); if x2> =0 then if x2< =4 then writeln(-2*x2: 10: 20); if x2< 0 then writeln(exp(cos(x2)): 10: 20); if x3> 4 then writeln(sqrt(abs(sin(sqr(x3)-1)/cos(sqr(x3)-: 10: 20); if x3> =0 then if x1< =4 then writeln(-2*x3: 10: 20); if x3< 0 then writeln(exp(cos(x3)): 10: 20); readln(x1); end.
Насколько я понял нужно не всю дату, а только 2006 год написать. вот алгоритм, который это делает: использовать робот алг нач | закрасить вверх закрасить вверх закрасить вверх вверх закрасить вправо закрасить вправо закрасить вниз закрасить вниз закрасить влево закрасить вправо вниз вниз закрасить влево закрасить вправо вправо вправо | закрасить вверх закрасить вверх закрасить вверх закрасить вверх закрасить вправо закрасить вправо закрасить вниз закрасить вниз закрасить вниз закрасить вниз закрасить влево закрасить вправо вправо вправо | закрасить вверх закрасить вверх закрасить вверх закрасить вверх закрасить вправо закрасить вправо закрасить вниз закрасить вниз закрасить вниз закрасить вниз закрасить влево закрасить вправо вправо вправо | закрасить вверх закрасить вверх закрасить вверх закрасить вверх закрасить вправо закрасить вправо закрасить вниз вниз закрасить влево закрасить вправо вниз закрасить вниз закрасить влево закрасить вправо вправо вправо кон